Skip to content
Laskyr

Plugins · wishsuite · data as of 2026-11-04

Is WishSuite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.10)

As of 2026-11-04. 5 issues are on record for older versions; version 1.5.2 or newer fixes all of them that state a fix.

Latest version
1.5.10
Last updated
2026-08-27
Active installs
1,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

WishSuite integrates wishlist functionality into your WooCommerce store, so customers can easily add products to their wishlists for later purchases. — by HT Plugins

What to do

  1. Update to the latest version (1.5.10). Anything older than 1.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wishsuite --field=version shows what you run; wp plugin update wishsuite updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-13838 · published 2025-12-21

Stored cross-site scripting (XSS) in WishSuite (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WishSuite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'button_text' parameter of the 'wishsuite_button' shortcode in all versions up to, and including, 1.5.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13838Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2025-30820 · published 2025-03-27

File inclusion in WishSuite (1.4.4 and older)

Affected
1.4.4 and older
Fixed in
1.4.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in HT Plugins WishSuite wishsuite allows PHP Local File Inclusion.This issue affects WishSuite: from n/a through <= 1.4.4.

NVD CVE-2025-30820Patchstack advisory

medium 5.4 CVE-2024-29927 · published 2024-03-27

Stored cross-site scripting (XSS) in WishSuite (1.3.7 and older)

Affected
1.3.7 and older
Fixed in
1.3.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in HasTheme WishSuite allows Stored XSS.This issue affects WishSuite: from n/a through 1.3.7.

NVD CVE-2024-29927Patchstack advisory

medium 4.8 CVE-2023-32962 · published 2023-08-30

Stored cross-site scripting (XSS) in WishSuite (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in HasTheme WishSuite – Wishlist for WooCommerce plugin <= 1.3.4 versions.

NVD CVE-2023-32962Patchstack advisory

high 8.8 CVE-2023-23731 · published 2023-07-11

Cross-site request forgery (CSRF) in WishSuite (1.3.3 and older)

Affected
1.3.3 and older
Fixed in
1.3.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in HasTheme WishSuite plugin <= 1.3.3 versions.

NVD CVE-2023-23731Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WishSuite vulnerability status badge
<a href="https://laskyr.com/plugins/wishsuite"><img src="https://laskyr.com/plugins/wishsuite/badge.svg" alt="WishSuite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit