Plugins · wish-list-for-woocommerce · data as of 2026-11-04
Is Wishlist for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 3.6.0
- Last updated
- 2026-10-05
- Active installs
- 2,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6.0+
Increase loyalty & sales by letting customers create, manage & share multiple wishlists on your WooCommerce store. — by WPFactory
What to do
- Update to the latest version (3.6.0). Anything older than 3.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wish-list-for-woocommerce --field=version shows what you run; wp plugin update wish-list-for-woocommerce updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2025-69334 · published 2026-01-06
Stored cross-site scripting (XSS) in Wishlist for WooCommerce (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPFactory Wishlist for WooCommerce wish-list-for-woocommerce allows Stored XSS.This issue affects Wishlist for WooCommerce: from n/a through <= 3.3.0.
medium 6.5 CVE-2025-49319 · published 2025-07-16
Missing authorization check in Wishlist for WooCommerce (3.2.3 and older)
- Affected
- 3.2.3 and older
- Fixed in
- 3.2.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WPFactory Wishlist for WooCommerce wish-list-for-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Wishlist for WooCommerce: from n/a through <= 3.2.3.
medium 6.5 CVE-2025-48237 · published 2025-05-19
Stored cross-site scripting (XSS) in Wishlist for WooCommerce (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPFactory Wishlist for WooCommerce wish-list-for-woocommerce allows Stored XSS.This issue affects Wishlist for WooCommerce: from n/a through <= 3.2.2.
medium 6.5 CVE-2024-13774 · published 2025-03-08
Cross-site request forgery (CSRF) in Wishlist for WooCommerce (3.1.7 and older)
- Affected
- 3.1.7 and older
- Fixed in
- 3.1.8 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Wishlist for WooCommerce: Multi Wishlists Per Customer plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.1.7. This is due to missing or incorrect nonce validation on the 'save_to_multiple_wishlist' function. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
high 7.1 CVE-2024-56228 · published 2024-12-31
Cross-site scripting (XSS) in Wishlist for WooCommerce (3.1.2 and older)
- Affected
- 3.1.2 and older
- Fixed in
- 3.1.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPFactory Wishlist for WooCommerce wish-list-for-woocommerce.This issue affects Wishlist for WooCommerce: from n/a through <= 3.1.2.
medium 6.1 CVE-2024-10519 · published 2024-11-23
Reflected cross-site scripting (XSS) in Wishlist for WooCommerce (3.0.8 up to (not including) 3.1.3)
- Affected
- 3.0.8 up to (not including) 3.1.3
- Fixed in
- 3.1.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by Wordfence
Details from the advisory
The Wishlist for WooCommerce: Multi Wishlists Per Customer PRO plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'wtab' parameter in versions 3.0.8 to 3.1.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. Note: Only WordPress installations with versions of PHP <=7.4 are affected by this vulnerability.
NVD CVE-2024-10519Wordfence advisoryCode change (fix)wordpress.orggithub.comgithub.comPlugin source
Recent activity
- 2026-10-05 — latest release on wordpress.org (3.6.0).
- 2026-01-06 — Stored cross-site scripting (XSS) disclosed (CVE-2025-69334), fixed in 3.3.1.
- 2025-07-16 — Missing authorization check disclosed (CVE-2025-49319), fixed in 3.2.4.
- 2025-05-19 — Stored cross-site scripting (XSS) disclosed (CVE-2025-48237), fixed in 3.2.3.
Get an email when Wishlist for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Wishlist for WooCommerce (wish-list-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPFactory (9 tracked)
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wish-list-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wish-list-for-woocommerce"><img src="https://laskyr.com/plugins/wish-list-for-woocommerce/badge.svg" alt="Wishlist for WooCommerce vulnerability status"></a>