Plugins · wisecampaign · data as of 2026-11-04
Is wiseCampaign safe? Known vulnerabilities and latest version
- Latest version
- 2.1.0
- Last updated
- 2026-11-03
- Active installs
- 40+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Boost WooCommerce sales with flash sale banners, exit-intent popups, countdown timers, direct checkout, stock bars and dynamic discounts. — by Wisemattic
What to do
- Update to the latest version (2.1.0). Anything older than 1.1.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wisecampaign --field=version shows what you run; wp plugin update wisecampaign updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-7529 · published 2026-08-05
Missing authorization check in wiseCampaign (1.1.16 and older)
- Affected
- 1.1.16 and older
- Fixed in
- 1.1.17 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The wiseCampaign – WooCommerce Conversions Made Easy plugin for WordPress is vulnerable to unauthorized modification and disclosure of data due to every one of its REST API endpoints being registered with `permission_callback => '__return_true'` in all versions up to, and including, 1.1.16. This makes it possible for unauthenticated attackers to read and modify the plugin's banner, stockbar, and core settings — including saving/updating banner records, toggling stockbar/feature flags, changing the active banner, and uploading background-image files via wp_handle_upload() — without any nonce or capability check.
NVD CVE-2026-7529Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-11-03 — latest release on wordpress.org (2.1.0).
- 2026-08-05 — Missing authorization check disclosed (CVE-2026-7529), fixed in 1.1.17.
Get an email when wiseCampaign has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for wiseCampaign (wisecampaign) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wisecampaign (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wisecampaign"><img src="https://laskyr.com/plugins/wisecampaign/badge.svg" alt="wiseCampaign vulnerability status"></a>