Plugins · wise-chat · data as of 2026-11-04
Is Wise Chat safe? Known vulnerabilities and latest version
- Latest version
- 3.4.5
- Last updated
- 2026-10-25
- Active installs
- 4,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.2 · PHP 7.4+
Advanced chat plugin for WordPress with AI ChatGPT bots. Requires no server, supports multiple channels, appearance settings, moderation, bans. — by Marcin
What to do
- Update to the latest version (3.4.5). Anything older than 3.4.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wise-chat --field=version shows what you run; wp plugin update wise-chat updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-39730 · published 2026-10-06
Missing authorization check in Wise Chat (3.4.3 and older)
- Affected
- 3.4.3 and older
- Fixed in
- 3.4.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Marcin Wise Chat wise-chat allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Wise Chat: from n/a through 3.4.3.
high 8.1 CVE-2026-81784 · published 2026-09-10
PHP object injection in Wise Chat (3.4.2 and older)
- Affected
- 3.4.2 and older
- Fixed in
- 3.4.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in Marcin Wise Chat wise-chat allows Object Injection.This issue affects Wise Chat: from n/a through 3.4.2.
medium 6.5 CVE-2026-66636 · published 2026-08-18
Stored cross-site scripting (XSS) in Wise Chat (3.4.3 and older)
- Affected
- 3.4.3 and older
- Fixed in
- 3.4.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Marcin Wise Chat wise-chat allows Stored XSS.This issue affects Wise Chat: from n/a through 3.4.3.
high 7.2 CVE-2025-3774 · published 2025-06-17
Stored cross-site scripting (XSS) in Wise Chat (3.3.4 and older)
- Affected
- 3.3.4 and older
- Fixed in
- 3.3.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Wise Chat plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the X-Forwarded-For header in all versions up to, and including, 3.3.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
high 7.5 CVE-2024-13613 · published 2025-05-17
Information disclosure in Wise Chat (3.3.2 and older)
- Affected
- 3.3.2 and older
- Fixed in
- 3.3.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Wise Chat plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.3.3 via the 'uploads' directory. This makes it possible for unauthenticated attackers to extract sensitive data stored insecurely in the /wp-content/uploads directory which can contain file attachments included in chat messages. The vulnerability was partially patched in version 3.3.3.
NVD CVE-2024-13613Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2023-32504 · published 2023-11-18
Cross-site request forgery (CSRF) in Wise Chat (3.1.3 and older)
- Affected
- 3.1.3 and older
- Fixed in
- 3.1.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Kainex Wise Chat.This issue affects Wise Chat: from n/a through 3.1.3.
medium 6.1 CVE-2019-6780 · published 2019-01-24
Open redirect in Wise Chat (older than 2.7)
- Affected
- older than 2.7
- Fixed in
- 2.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Wise Chat plugin before 2.7 for WordPress mishandles external links because rendering/filters/post/WiseChatLinksPostFilter.php omits noopener and noreferrer.
NVD CVE-2019-6780Code change (fix)wordpress.orgexploit-db.com
Recent activity
- 2026-10-25 — latest release on wordpress.org (3.4.5).
- 2026-10-06 — Missing authorization check disclosed (CVE-2026-39730), fixed in 3.4.4.
- 2026-09-10 — PHP object injection disclosed (CVE-2026-81784), fixed in 3.4.3.
- 2026-08-18 — Stored cross-site scripting (XSS) disclosed (CVE-2026-66636), fixed in 3.4.4.
Get an email when Wise Chat has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Wise Chat (wise-chat) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Marcin (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1) · PHP object injection (1) · Sensitive data exposure (1) · Cross-site request forgery (CSRF) (1) · Open redirect (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wise-chat (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wise-chat"><img src="https://laskyr.com/plugins/wise-chat/badge.svg" alt="Wise Chat vulnerability status"></a>