Plugins · wise-analytics · data as of 2026-11-04
Is Wise Analytics safe? Known vulnerabilities and latest version
- Latest version
- 1.1.20
- Last updated
- 2026-01-25
- Active installs
- 50+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.4.0+
Your stats are private thing. No need to store them outside your server or give it for free! Wise Analytics is an advanced web traffic tracking and an … — by Marcin
What to do
- Update to the latest version (1.1.20). Anything older than 1.1.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wise-analytics --field=version shows what you run; wp plugin update wise-analytics updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2025-14609 · published 2026-01-24
Missing authorization check in Wise Analytics (1.1.9 and older)
- Affected
- 1.1.9 and older
- Fixed in
- 1.1.20 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Wise Analytics plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 1.1.9. This is due to missing capability checks on the REST API endpoint '/wise-analytics/v1/report'. This makes it possible for unauthenticated attackers to access sensitive analytics data including administrator usernames, login timestamps, visitor tracking information, and business intelligence data via the 'name' parameter granted they can send unauthenticated requests.
NVD CVE-2025-14609Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-01-25 — latest release on wordpress.org (1.1.20).
- 2026-01-24 — Missing authorization check disclosed (CVE-2025-14609), fixed in 1.1.20.
Get an email when Wise Analytics has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Wise Analytics (wise-analytics) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Marcin (2 tracked)
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wise-analytics (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wise-analytics"><img src="https://laskyr.com/plugins/wise-analytics/badge.svg" alt="Wise Analytics vulnerability status"></a>