Plugins · widget-countdown · data as of 2026-11-04
Is Countdown Timer safe? Known vulnerabilities and latest version
- Status
- Closed 2026-10-06
- Known issues on record
- 5
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate widget-countdown && wp plugin delete widget-countdown
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.
medium 6.4 CVE-2026-16495 · published 2026-10-14
Stored cross-site scripting (XSS) in Countdown Timer (3.0.0 to 3.0.1)
- Affected
- 3.0.0 to 3.0.1
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Countdown Timer – Widget Countdown plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'redirect_url' Shortcode Attribute in all versions up to, and including, 3.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 6.4 CVE-2025-14555 · published 2026-01-10
Stored cross-site scripting (XSS) in Countdown Timer (2.7.7 and older)
- Affected
- 2.7.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Countdown Timer – Widget Countdown plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'wpdevart_countdown' shortcode in all versions up to, and including, 2.7.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-14555Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-47443 · published 2025-05-07
Stored cross-site scripting (XSS) in Countdown Timer (2.7.4 and older)
- Affected
- 2.7.4 and older
- Fixed in
- 2.7.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpdevart Widget Countdown widget-countdown allows Stored XSS.This issue affects Widget Countdown: from n/a through <= 2.7.4.
high 7.1 CVE-2024-13864 · published 2025-03-11
Reflected cross-site scripting (XSS) in Countdown Timer (1.0 and older)
- Affected
- 1.0 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Countdown Timer WordPress plugin through 1.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
medium 6.5 CVE-2025-24719 · published 2025-01-24
Stored cross-site scripting (XSS) in Countdown Timer (2.7.1 and older)
- Affected
- 2.7.1 and older
- Fixed in
- 2.7.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpdevart Widget Countdown widget-countdown allows Stored XSS.This issue affects Widget Countdown: from n/a through <= 2.7.1.
Recent activity
- 2026-10-06 — closed on wordpress.org.
- 2026-10-14 — Stored cross-site scripting (XSS) disclosed (CVE-2026-16495), fix version not stated.
- 2026-01-10 — Stored cross-site scripting (XSS) disclosed (CVE-2025-14555), fix version not stated.
- 2025-05-07 — Stored cross-site scripting (XSS) disclosed (CVE-2025-47443), fixed in 2.7.5.
Get an email when Countdown Timer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Countdown Timer (widget-countdown) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (5)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/widget-countdown (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/widget-countdown"><img src="https://laskyr.com/plugins/widget-countdown/badge.svg" alt="Countdown Timer vulnerability status"></a>