Plugins · widget-context · data as of 2026-11-04
Is Widget Context safe? Known vulnerabilities and latest version
- Latest version
- 1.5.0
- Last updated
- 2026-10-09
- Active installs
- 30,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Show and hide widgets on specific posts, pages and sections of your site. — by Kaspars
What to do
- Update to the latest version (1.5.0). Anything older than 1.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get widget-context --field=version shows what you run; wp plugin update widget-context updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2026-7615 · published 2026-05-22
Cross-site request forgery (CSRF) in Widget Context (1.3.3 and older)
- Affected
- 1.3.3 and older
- Fixed in
- 1.4.0 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Widget Context plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.3.3. This is due to missing or incorrect nonce validation on the save_widget_context_settings function. This makes it possible for unauthenticated attackers to modify widget visibility context settings stored in the WordPress options table via a forged POST request to /wp-admin/widgets.php via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Recent activity
- 2026-10-09 — latest release on wordpress.org (1.5.0).
- 2026-05-22 — Cross-site request forgery (CSRF) disclosed (CVE-2026-7615), fixed in 1.4.0.
Get an email when Widget Context has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Widget Context (widget-context) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/widget-context (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/widget-context"><img src="https://laskyr.com/plugins/widget-context/badge.svg" alt="Widget Context vulnerability status"></a>