Plugins · wholesale-market · data as of 2026-11-04
Is Wholesale Market safe? Known vulnerabilities and latest version
- Status
- Closed 2026-08-03
- Known issues on record
- 3
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate wholesale-market && wp plugin delete wholesale-market
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 3 record(s) do not state which versions are affected.
high 8.8 CVE-2026-14279 · published 2026-08-15
Privilege escalation in Wholesale Market (2.2.2 and older)
- Affected
- 2.2.2 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Wholesale Market plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 2.2.2 via the ced_wholesale_request_send AJAX action. The ced_wholesale_request_send_callback() handler only verifies a nonce (which is exposed to any authenticated user through wp_localize_script on the frontend) and that the caller has a positive user ID, then calls WP_User::add_role() with the client-supplied role_required POST parameter without restricting the value to an allowlist of wholesale roles. This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges to Administrator when the site administrator has enabled the 'Assigning requested role directly' option.
medium 6.5 CVE-2022-4363 · published 2025-05-16
Cross-site request forgery (CSRF) in Wholesale Market (older than 2.2.2)
- Affected
- older than 2.2.2
- Fixed in
- 2.2.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Wholesale Market WordPress plugin before 2.2.2, Wholesale Market for WooCommerce WordPress plugin before 2.0.1 have a flawed CSRF check when updating their settings, which could allow attackers to make a logged in admin update them via a CSRF attack
critical 9.8 CVE-2022-4298 · published 2023-01-02
Security issue in Wholesale Market (older than 2.2.1)
- Affected
- older than 2.2.1
- Fixed in
- 2.2.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Wholesale Market WordPress plugin before 2.2.1 does not have authorisation check, as well as does not validate user input used to generate system path, allowing unauthenticated attackers to download arbitrary file from the server.
Recent activity
- 2026-08-03 — closed on wordpress.org (Security Issue).
- 2026-08-15 — Privilege escalation disclosed (CVE-2026-14279), fix version not stated.
- 2025-05-16 — Cross-site request forgery (CSRF) disclosed (CVE-2022-4363), fixed in 2.2.2.
- 2023-01-02 — Security issue disclosed (CVE-2022-4298), fixed in 2.2.1.
Get an email when Wholesale Market has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Wholesale Market (wholesale-market) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Privilege escalation (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/wholesale-market (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wholesale-market"><img src="https://laskyr.com/plugins/wholesale-market/badge.svg" alt="Wholesale Market vulnerability status"></a>