Plugins · whmcs-bridge · data as of 2026-11-04
Is WHMCS Bridge safe? Known vulnerabilities and latest version
- Status
- Closed 2026-07-06
- Known issues on record
- 3
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate whmcs-bridge && wp plugin delete whmcs-bridge
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 3 record(s) do not state which versions are affected.
high 8.8 CVE-2026-14489 · published 2026-07-08
Arbitrary file upload in WHMCS Bridge (6.9 and older)
- Affected
- 6.9 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WHMCS Bridge plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the connect() function in all versions up to, and including, 6.9. This makes it possible for authenticated attackers, with Custom-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible.
medium 6.1 CVE-2021-25112 · published 2022-02-28
Reflected cross-site scripting (XSS) in WHMCS Bridge (older than 6.4b)
- Affected
- older than 6.4b
- Fixed in
- 6.4b
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The WHMCS Bridge WordPress plugin before 6.4b does not sanitise and escape the error parameter before outputting it back in admin dashboard, leading to a Reflected Cross-Site Scripting
medium 5.4 CVE-2021-4074 · published 2022-01-18
Stored cross-site scripting (XSS) in WHMCS Bridge (6.1 to 6.1)
- Affected
- 6.1 to 6.1
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WHMCS Bridge WordPress plugin is vulnerable to Stored Cross-Site Scripting via the cc_whmcs_bridge_url parameter found in the ~/whmcs-bridge/bridge_cp.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 6.1. Due to missing authorization checks on the cc_whmcs_bridge_add_admin function, low-level authenticated users such as subscribers can exploit this vulnerability.
Recent activity
- 2026-07-06 — closed on wordpress.org (Security Issue).
- 2026-07-08 — Arbitrary file upload disclosed (CVE-2026-14489), fix version not stated.
- 2022-02-28 — Reflected cross-site scripting (XSS) disclosed (CVE-2021-25112), fixed in 6.4b.
- 2022-01-18 — Stored cross-site scripting (XSS) disclosed (CVE-2021-4074), fix version not stated.
Get an email when WHMCS Bridge has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WHMCS Bridge (whmcs-bridge) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Arbitrary file upload (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/whmcs-bridge (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/whmcs-bridge"><img src="https://laskyr.com/plugins/whmcs-bridge/badge.svg" alt="WHMCS Bridge vulnerability status"></a>