Skip to content
Laskyr

Plugins · white-label-cms · data as of 2026-11-04

Is White Label CMS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.14)

As of 2026-11-04. 5 issues are on record for older versions; version 2.7.13 or newer fixes all of them that state a fix.

Latest version
2.7.14
Last updated
2026-07-09
Active installs
200,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.4+

Customise dashboard panels and branding, hide menus plus lots more. — by Video User Manuals

What to do

  1. Update to the latest version (2.7.14). Anything older than 2.7.13 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get white-label-cms --field=version shows what you run; wp plugin update white-label-cms updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-11898 · published 2026-07-11

Stored cross-site scripting (XSS) in White Label CMS (2.7.12 and older)

Affected
2.7.12 and older
Fixed in
2.7.13 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The White Label CMS plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 2.7.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-11898Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2024-43303 · published 2024-08-18

Reflected cross-site scripting (XSS) in White Label CMS (2.7.4 and older)

Affected
2.7.4 and older
Fixed in
2.7.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in videousermanuals.Com White Label CMS allows Reflected XSS.This issue affects White Label CMS: from n/a through 2.7.4.

NVD CVE-2024-43303Patchstack advisory

medium 5.3 CVE-2024-4280 · published 2024-05-14

Missing authorization check in White Label CMS (2.7.3 and older)

Affected
2.7.3 and older
Fixed in
2.7.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The White Label CMS plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the reset_plugin function in all versions up to, and including, 2.7.3. This makes it possible for unauthenticated attackers to reset plugin settings.

NVD CVE-2024-4280Wordfence advisoryCode change (fix)

high 7.2 CVE-2022-4302 · published 2023-01-02

PHP object injection in White Label CMS (older than 2.5)

Affected
older than 2.5
Fixed in
2.5
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The White Label CMS WordPress plugin before 2.5 unserializes user input provided via the settings, which could allow high-privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.

NVD CVE-2022-4302WPScan advisory

medium 6.1 CVE-2022-0422 · published 2022-03-07

Reflected cross-site scripting (XSS) in White Label CMS (older than 2.2.9)

Affected
older than 2.2.9
Fixed in
2.2.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The White Label CMS WordPress plugin before 2.2.9 does not sanitise and validate the wlcms[_login_custom_js] parameter before outputting it back in the response while previewing, leading to a Reflected Cross-Site Scripting issue

NVD CVE-2022-0422WPScan advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
White Label CMS vulnerability status badge
<a href="https://laskyr.com/plugins/white-label-cms"><img src="https://laskyr.com/plugins/white-label-cms/badge.svg" alt="White Label CMS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit