Plugins · wh-tweaks · data as of 2026-11-04
Is WH Tweaks safe? Known vulnerabilities and latest version
- Latest version
- 1.0.3
- Last updated
- 2026-01-07
- Active installs
- 90+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Common functionality WordPress core should have but maybe shouldn't. — by webheadcoder
What to do
- Update to the latest version (1.0.3). Anything older than 1.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wh-tweaks --field=version shows what you run; wp plugin update wh-tweaks updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.9 CVE-2025-67630 · published 2025-12-24
Stored cross-site scripting (XSS) in WH Tweaks (1.0.2 and older)
- Affected
- 1.0.2 and older
- Fixed in
- 1.0.3
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in webheadcoder WH Tweaks wh-tweaks allows Stored XSS.This issue affects WH Tweaks: from n/a through <= 1.0.2.
Recent activity
- 2026-01-07 — latest release on wordpress.org (1.0.3).
- 2025-12-24 — Stored cross-site scripting (XSS) disclosed (CVE-2025-67630), fixed in 1.0.3.
Get an email when WH Tweaks has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WH Tweaks (wh-tweaks) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by webheadcoder (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wh-tweaks (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wh-tweaks"><img src="https://laskyr.com/plugins/wh-tweaks/badge.svg" alt="WH Tweaks vulnerability status"></a>