Plugins · wemail · data as of 2026-11-04
Is weMail safe? Known vulnerabilities and latest version
- Status
- Closed 2026-10-23
- Known issues on record
- 8
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate wemail && wp plugin delete wemail
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 8 record(s) do not state which versions are affected.
not scored yet CVE-2026-104647 · published 2026-11-03
Security issue in weMail (2.1.6 and older)
- Affected
- 2.1.6 and older
- Fixed in
- unknown
- Range from
- CVE record (the advisory publisher)
Details from the advisory
The weMail WordPress plugin through 2.1.6 does not correctly verify user capabilities in its REST API permission checks, treating any user whose role is in the weMail WordPress plugin through 2.1.6's allowed-roles list (Editor and above by default) as authorised for every action, which allows such users to perform administrator-level actions including enumerating all registered users with their email addresses and modifying the weMail WordPress plugin through 2.1.6's own access-control configuration.
not scored yet CVE-2026-104648 · published 2026-11-03
Security issue in weMail (2.1.6 and older)
- Affected
- 2.1.6 and older
- Fixed in
- unknown
- Range from
- CVE record (the advisory publisher)
Details from the advisory
The weMail WordPress plugin through 2.1.6 does not restrict a site-wide third-party email-service API key to administrators, exposing it in an admin screen that users with the Editor role can reach by default, which allows them to obtain a reusable credential usable without a WordPress session to impersonate other users and sever the site's email-service connection.
high 7.1 CVE-2026-57322 · published 2026-06-26
Reflected cross-site scripting (XSS) in weMail (2.1.2 and older)
- Affected
- 2.1.2 and older
- Fixed in
- 2.1.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in weDevs weMail wemail allows Reflected XSS.This issue affects weMail: from n/a through 2.1.2.
medium 6.5 CVE-2025-14339 · published 2026-02-21
Missing authorization check in weMail (2.0.7 and older)
- Affected
- 2.0.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The weMail - Email Marketing, Lead Generation, Optin Forms, Email Newsletters, A/B Testing, and Automation plugin for WordPress is vulnerable to unauthorized form deletion in all versions up to, and including, 2.0.7. This is due to the `Forms::permission()` callback only validating the `X-WP-Nonce` header without checking user capabilities. Since the REST nonce is exposed to unauthenticated visitors via the `weMail` JavaScript object on pages with weMail forms, any unauthenticated user can permanently delete all weMail forms by extracting the nonce from the page source and sending a DELETE request to the forms endpoint.
NVD CVE-2025-14339Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2025-14348 · published 2026-01-20
Missing authorization check in weMail (2.0.7 and older)
- Affected
- 2.0.7 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The weMail - Email Marketing, Lead Generation, Optin Forms, Email Newsletters, A/B Testing, and Automation plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 2.0.7. This is due to the plugin's REST API trusting the `x-wemail-user` HTTP header to identify users without verifying the request originates from an authenticated WordPress session. This makes it possible for unauthenticated attackers who know or can guess an admin email (easily enumerable via `/wp-json/wp/v2/users`) to impersonate that user and access the CSV subscriber endpoints, potentially exfiltrating subscriber PII (emails, names, phone numbers) from imported CSV files.
NVD CVE-2025-14348Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2025-47540 · published 2025-05-07
Information disclosure in weMail (1.14.13 and older)
- Affected
- 1.14.13 and older
- Fixed in
- 1.14.14
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in weDevs weMail wemail allows Retrieve Embedded Sensitive Data.This issue affects weMail: from n/a through <= 1.14.13.
medium 6.1 CVE-2024-43238 · published 2024-08-18
Cross-site scripting (XSS) in weMail (1.14.5 and older)
- Affected
- 1.14.5 and older
- Fixed in
- 1.14.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in weDevs weMail wemail allows DOM-Based XSS.This issue affects weMail: from n/a through <= 1.14.5.
medium 5.3 CVE-2024-34822 · published 2024-06-11
Missing authorization check in weMail (1.14.2 and older)
- Affected
- 1.14.2 and older
- Fixed in
- 1.14.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Missing Authorization vulnerability in weDevs weMail.This issue affects weMail: from n/a through 1.14.2.
Recent activity
- 2026-10-23 — closed on wordpress.org.
- 2026-11-03 — Security issue disclosed (CVE-2026-104647), fix version not stated.
- 2026-11-03 — Security issue disclosed (CVE-2026-104648), fix version not stated.
- 2026-06-26 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-57322), fixed in 2.1.3.
Get an email when weMail has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for weMail (wemail) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/wemail (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wemail"><img src="https://laskyr.com/plugins/wemail/badge.svg" alt="weMail vulnerability status"></a>