Plugins · website-llms-txt · data as of 2026-11-04
Is Website LLMs.txt safe? Known vulnerabilities and latest version
- Latest version
- 8.6.3
- Last updated
- 2026-10-04
- Active installs
- 50,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.2+
Automatically generate and manage LLMS.txt files for LLM/AI content understanding, with full Yoast SEO, Rank Math, SEOPress, and AIOSEO integration. — by Ryan Howard
What to do
- Update to the latest version (8.6.3). Anything older than 8.2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get website-llms-txt --field=version shows what you run; wp plugin update website-llms-txt updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-6711 · published 2026-04-21
Reflected cross-site scripting (XSS) in Website LLMs.txt (8.2.6 and older)
- Affected
- 8.2.6 and older
- Fixed in
- 8.2.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Website LLMs.txt plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'tab' parameter in all versions up to, and including, 8.2.6. This is due to the use of filter_input() without a sanitization filter and insufficient output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick an administrator into performing an action such as clicking on a link.
medium 4.4 CVE-2026-6712 · published 2026-04-21
Stored cross-site scripting (XSS) in Website LLMs.txt (8.2.6 and older)
- Affected
- 8.2.6 and older
- Fixed in
- 8.2.7 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Website LLMs.txt plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 8.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
high 7.1 CVE-2026-27068 · published 2026-03-19
Reflected cross-site scripting (XSS) in Website LLMs.txt (8.2.6 and older)
- Affected
- 8.2.6 and older
- Fixed in
- 8.2.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ryan Howard Website LLMs.txt website-llms-txt allows Reflected XSS.This issue affects Website LLMs.txt: from n/a through <= 8.2.6.
Recent activity
- 2026-10-04 — latest release on wordpress.org (8.6.3).
- 2026-04-21 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-6711), fixed in 8.2.7.
- 2026-04-21 — Stored cross-site scripting (XSS) disclosed (CVE-2026-6712), fixed in 8.2.7.
- 2026-03-19 — Reflected cross-site scripting (XSS) disclosed (CVE-2026-27068), fixed in 8.2.7.
Get an email when Website LLMs.txt has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Website LLMs.txt (website-llms-txt) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/website-llms-txt (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/website-llms-txt"><img src="https://laskyr.com/plugins/website-llms-txt/badge.svg" alt="Website LLMs.txt vulnerability status"></a>