Skip to content
Laskyr

Plugins · webpushr-web-push-notifications · data as of 2026-11-04

Is Web Push Notifications safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.41.0)

As of 2026-11-04. 5 issues are on record for older versions; version 4.39.0 or newer fixes all of them that state a fix.

Latest version
4.41.0
Last updated
2026-07-28
Active installs
10,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 5.6+

Fastest growing & lightweight plugin for Web Push Notifications. Add browser push notifications to your WordPress & WooCommerce site. — by webpushr

What to do

  1. Update to the latest version (4.41.0). Anything older than 4.39.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get webpushr-web-push-notifications --field=version shows what you run; wp plugin update webpushr-web-push-notifications updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-9729 · published 2026-07-23

Stored cross-site scripting (XSS) in Web Push Notifications (4.39.0 and older)

Affected
4.39.0 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Webpushr Push Notifications plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'webpushr_notification_title' and 'webpushr_notification_body' parameters in versions up to, and including, 4.39.0. This is due to insufficient input sanitization in the save_send_notification_flag() function and missing output escaping in the wpp_notification_box() function, which concatenates raw post meta values directly into HTML attribute and textarea contexts. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-9729Wordfence advisoryPlugin source

medium 5.3 CVE-2026-24536 · published 2026-01-23

Information disclosure in Web Push Notifications (4.38.0 and older)

Affected
4.38.0 and older
Fixed in
4.39.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in webpushr Webpushr webpushr-web-push-notifications allows Retrieve Embedded Sensitive Data.This issue affects Webpushr: from n/a through <= 4.38.0.

NVD CVE-2026-24536Patchstack advisory

high 7.1 CVE-2024-34369 · published 2024-05-06

Reflected cross-site scripting (XSS) in Web Push Notifications (4.35.0 and older)

Affected
4.35.0 and older
Fixed in
4.36.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Webpushr Web Push Notifications Webpushr allows Reflected XSS.This issue affects Webpushr: from n/a through 4.35.0.

NVD CVE-2024-34369Patchstack advisory

medium 5.4 CVE-2023-5620 · published 2023-11-27

Stored cross-site scripting (XSS) in Web Push Notifications (older than 4.35.0)

Affected
older than 4.35.0
Fixed in
4.35.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Web Push Notifications WordPress plugin before 4.35.0 does not prevent visitors on the site from changing some of the plugin options, some of which may be used to conduct Stored XSS attacks.

NVD CVE-2023-5620WPScan advisory

high 8.8 CVE-2023-35041 · published 2023-11-13

Cross-site request forgery (CSRF) in Web Push Notifications (4.34.0 and older)

Affected
4.34.0 and older
Fixed in
4.35.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability leading to Local File Inclusion (LF) in Webpushr Web Push Notifications Web Push Notifications – Webpushr plugin <= 4.34.0 versions.

NVD CVE-2023-35041Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Web Push Notifications vulnerability status badge
<a href="https://laskyr.com/plugins/webpushr-web-push-notifications"><img src="https://laskyr.com/plugins/webpushr-web-push-notifications/badge.svg" alt="Web Push Notifications vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit