Plugins · webp-express · data as of 2026-11-01
Is WebP Express safe? Known vulnerabilities and latest version
- Latest version
- 0.25.16
- Last updated
- 2026-10-18
- Active installs
- 300,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 5.6+
Serve autogenerated WebP images instead of jpeg/png to browsers that supports WebP. — by rosell.dk
What to do
- Update to the latest version (0.25.16). Anything older than 0.25.16 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get webp-express --field=version shows what you run; wp plugin update webp-express updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-97328 · published 2026-10-22
Cross-site scripting (XSS) in WebP Express (older than 0.25.16)
- Affected
- older than 0.25.16
- Fixed in
- 0.25.16
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WebP Express WordPress plugin before 0.25.16 does not escape values that its bundled HTML parser re-emits into element attributes when a non-default image delivery mode is enabled, allowing unauthenticated users to submit content that is stored and later executed as Cross-Site Scripting in the browser of any user viewing an affected page, including administrators.
medium 5.3 CVE-2025-11379 · published 2025-12-04
Information disclosure in WebP Express (0.25.9 and older)
- Affected
- 0.25.9 and older
- Fixed in
- 0.25.10 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WebP Express plugin for WordPress is vulnerable to information exposure via config files in all versions up to, and including, 0.25.9. This is due to the plugin not properly randomizing the name of the config file to prevent direct access on NGINX. This makes it possible for unauthenticated attackers to extract configuration data.
NVD CVE-2025-11379Wordfence advisoryCode change (fix)wordpress.org
medium 5.4 CVE-2019-15837 · published 2019-08-30
Stored cross-site scripting (XSS) in WebP Express (older than 0.14.8)
- Affected
- older than 0.14.8
- Fixed in
- 0.14.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The webp-express plugin before 0.14.8 for WordPress has stored XSS.
high 7.5 CVE-2019-15330 · published 2019-08-22
Path traversal / file read in WebP Express (older than 0.14.11)
- Affected
- older than 0.14.11
- Fixed in
- 0.14.11
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The webp-express plugin before 0.14.11 for WordPress has insufficient protection against arbitrary file reading.
Recent activity
- 2026-10-18 — latest release on wordpress.org (0.25.16).
- 2026-10-22 — Cross-site scripting (XSS) disclosed (CVE-2026-97328), fixed in 0.25.16.
- 2025-12-04 — Information disclosure disclosed (CVE-2025-11379), fixed in 0.25.10.
- 2019-08-30 — Stored cross-site scripting (XSS) disclosed (CVE-2019-15837), fixed in 0.14.8.
Get an email when WebP Express has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WebP Express (webp-express) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/webp-express (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/webp-express"><img src="https://laskyr.com/plugins/webp-express/badge.svg" alt="WebP Express vulnerability status"></a>