Plugins · webp-converter-for-media · data as of 2026-11-01
Is Converter for Media safe? Known vulnerabilities and latest version
- Latest version
- 6.7.1
- Last updated
- 2026-10-30
- Active installs
- 500,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Speed up your website by using our WebP & AVIF Converter. Optimize images and serve WebP and AVIF images instead of standard formats! — by Mateusz Gbiorczyk
What to do
- Update to the latest version (6.7.1). Anything older than 6.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get webp-converter-for-media --field=version shows what you run; wp plugin update webp-converter-for-media updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.8 CVE-2026-1356 · published 2026-02-12
Server-side request forgery (SSRF) in Converter for Media (6.5.1 and older)
- Affected
- 6.5.1 and older
- Fixed in
- 6.5.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Converter for Media – Optimize images | Convert WebP & AVIF plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 6.5.1 via the PassthruLoader::load_image_source function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
medium 4.3 CVE-2025-13750 · published 2025-12-17
Missing authorization check in Converter for Media (6.3.2 and older)
- Affected
- 6.3.2 and older
- Fixed in
- 6.4.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Converter for Media – Optimize images | Convert WebP & AVIF plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the `/webp-converter/v1/regenerate-attachment` REST endpoint in all versions up to, and including, 6.3.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete optimized WebP/AVIF variants for arbitrary attachments.
high 8.8 CVE-2019-15834 · published 2019-08-30
Cross-site request forgery (CSRF) in Converter for Media (older than 1.0.3)
- Affected
- older than 1.0.3
- Fixed in
- 1.0.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The webp-converter-for-media plugin before 1.0.3 for WordPress has CSRF.
Recent activity
- 2026-10-30 — latest release on wordpress.org (6.7.1).
- 2026-02-12 — Server-side request forgery (SSRF) disclosed (CVE-2026-1356), fixed in 6.5.2.
- 2025-12-17 — Missing authorization check disclosed (CVE-2025-13750), fixed in 6.4.0.
- 2019-08-30 — Cross-site request forgery (CSRF) disclosed (CVE-2019-15834), fixed in 1.0.3.
Get an email when Converter for Media has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Converter for Media (webp-converter-for-media) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/webp-converter-for-media (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/webp-converter-for-media"><img src="https://laskyr.com/plugins/webp-converter-for-media/badge.svg" alt="Converter for Media vulnerability status"></a>