Plugins · webmention · data as of 2026-11-04
Is Webmention safe? Known vulnerabilities and latest version
- Latest version
- 5.11.0
- Last updated
- 2026-10-21
- Active installs
- 900+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Send and receive Webmentions in WordPress. — by Matthias Pfefferle
What to do
- Update to the latest version (5.11.0). Anything older than 5.10.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get webmention --field=version shows what you run; wp plugin update webmention updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2026-111109 · published 2026-10-31
Stored cross-site scripting (XSS) in Webmention (5.10.1 and older)
- Affected
- 5.10.1 and older
- Fixed in
- 5.10.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Webmention plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Open Graph og:title meta tag of a webmention source URL in versions up to, and including, 5.10.1. This is due to insufficient input sanitization: Meta::add_properties() maps og:title to the Item::name property, but Item has no concrete set_name() method, so Item::__call() stores the value raw while sibling set_content()/set_summary() paths route through webmention_sanitize_html(); Item::get_content() then falls back to the raw name when content and summary are empty, and Receiver::process() explicitly removes the core wp_filter_kses / wp_filter_post_kses hooks on pre_comment_content before calling wp_new_comment(), so the payload is persisted to comment_content as-is. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page, after an administrator approves the resulting pending webmention comment. Successful exploitation additionally requires an action by an administrator — the attacker cannot trigger the vulnerability on their own.
NVD CVE-2026-111109Wordfence advisorygithub.comPlugin source
high 7.2 CVE-2026-10513 · published 2026-06-30
Stored cross-site scripting (XSS) in Webmention (5.8.0 and older)
- Affected
- 5.8.0 and older
- Fixed in
- 5.8.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Webmention plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to and including 5.8.0 via parser-derived 'avatar' and 'url' author metadata. This is due to insufficient input sanitization and output escaping on user-supplied MF2 author properties processed by the unauthenticated webmention REST endpoint and rendered directly into HTML 'value' attributes by the edit-comment-form template without esc_attr() or esc_url(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a privileged user (moderator or administrator) opens the affected comment edit screen.
NVD CVE-2026-10513Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-0688 · published 2026-04-02
Server-side request forgery (SSRF) in Webmention (5.6.2 and older)
- Affected
- 5.6.2 and older
- Fixed in
- 5.7.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Webmention plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 5.6.2 via the 'Tools::read' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
NVD CVE-2026-0688Wordfence advisoryCode change (fix)github.comPlugin source
high 7.2 CVE-2026-0686 · published 2026-04-02
Server-side request forgery (SSRF) in Webmention (5.6.2 and older)
- Affected
- 5.6.2 and older
- Fixed in
- 5.7.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Webmention plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 5.6.2 in the 'MF2::parse_authorpage' function via the 'Receiver::post' function. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
NVD CVE-2026-0686Wordfence advisoryCode change (fix)github.comPlugin source
Recent activity
- 2026-10-21 — latest release on wordpress.org (5.11.0).
- 2026-10-31 — Stored cross-site scripting (XSS) disclosed (CVE-2026-111109), fixed in 5.10.2.
- 2026-06-30 — Stored cross-site scripting (XSS) disclosed (CVE-2026-10513), fixed in 5.8.1.
- 2026-04-02 — Server-side request forgery (SSRF) disclosed (CVE-2026-0688), fixed in 5.7.0.
Get an email when Webmention has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Webmention (webmention) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Server-side request forgery (SSRF) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/webmention (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/webmention"><img src="https://laskyr.com/plugins/webmention/badge.svg" alt="Webmention vulnerability status"></a>