Skip to content
Laskyr

Plugins · webman-amplifier · data as of 2026-11-04

Is WebMan Amplifier safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.3)

As of 2026-11-04. 1 issue is on record for older versions; version 1.6.0 or newer fixes all of them that state a fix.

Latest version
1.6.3
Last updated
2026-03-13
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.0+

Amplifies functionality of WP themes. Provides custom post types, shortcodes, metaboxes, icons. Theme developer's best friend! — by WebMan Design | Oliver Juhas

What to do

  1. Update to the latest version (1.6.3). Anything older than 1.6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get webman-amplifier --field=version shows what you run; wp plugin update webman-amplifier updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-62757 · published 2025-12-31

Cross-site scripting (XSS) in WebMan Amplifier (1.5.12 and older)

Affected
1.5.12 and older
Fixed in
1.6.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WebMan Design | Oliver Juhas WebMan Amplifier webman-amplifier allows DOM-Based XSS.This issue affects WebMan Amplifier: from n/a through <= 1.5.12.

NVD CVE-2025-62757Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WebMan Amplifier vulnerability status badge
<a href="https://laskyr.com/plugins/webman-amplifier"><img src="https://laskyr.com/plugins/webman-amplifier/badge.svg" alt="WebMan Amplifier vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit