Plugins · webling · data as of 2026-11-04
Is Webling safe? Known vulnerabilities and latest version
- Latest version
- 3.9.2
- Last updated
- 2026-08-17
- Active installs
- 500+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Anmeldeformulare und Mitgliederdaten aus der Vereinssoftware webling.eu auf deiner Webseite anzeigen. — by uSystems
What to do
- Update to the latest version (3.9.2). Anything older than 3.9.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get webling --field=version shows what you run; wp plugin update webling updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-1263 · published 2026-04-10
Stored cross-site scripting (XSS) in Webling (3.9.0 and older)
- Affected
- 3.9.0 and older
- Fixed in
- 3.9.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Webling plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 3.9.0 due to insufficient input sanitization, insufficient output escaping, and missing capabilities checks in the 'webling_admin_save_form' and 'webling_admin_save_memberlist' functions. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject Webling forms and memberlists with arbitrary web scripts that will execute whenever an administrator views the related form or memberlist area of the WordPress admin.
NVD CVE-2026-1263Wordfence advisoryCode change (fix)Plugin source
medium 5.9 CVE-2025-31806 · published 2025-04-01
Stored cross-site scripting (XSS) in Webling (3.9.0 and older)
- Affected
- 3.9.0 and older
- Fixed in
- 3.9.1
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in uSystems Webling webling allows Stored XSS.This issue affects Webling: from n/a through <= 3.9.0.
Recent activity
- 2026-08-17 — latest release on wordpress.org (3.9.2).
- 2026-04-10 — Stored cross-site scripting (XSS) disclosed (CVE-2026-1263), fixed in 3.9.1.
- 2025-04-01 — Stored cross-site scripting (XSS) disclosed (CVE-2025-31806), fixed in 3.9.1.
Get an email when Webling has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Webling (webling) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/webling (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/webling"><img src="https://laskyr.com/plugins/webling/badge.svg" alt="Webling vulnerability status"></a>