Plugins · webd-woocommerce-advanced-reporting-statistics · data as of 2026-11-04
Is Advanced Reporting and Statistics for WooComme… safe? Known vulnerabilities and latest version
- Status
- Closed 2026-04-27
- Known issues on record
- 3
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate webd-woocommerce-advanced-reporting-statistics && wp plugin delete webd-woocommerce-advanced-reporting-statistics
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 3 record(s) do not state which versions are affected.
critical 9.3 CVE-2026-24993 · published 2026-03-25
SQL injection in Advanced Reporting and Statistics for WooComme… (4.1.3 and older)
- Affected
- 4.1.3 and older
- Fixed in
- 4.1.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WPFactory Advanced WooCommerce Product Sales Reporting webd-woocommerce-advanced-reporting-statistics allows Blind SQL Injection.This issue affects Advanced WooCommerce Product Sales Reporting: from n/a through <= 4.1.3.
medium 5.3 CVE-2026-24992 · published 2026-02-03
Information disclosure in Advanced Reporting and Statistics for WooComme… (4.1.2 and older)
- Affected
- 4.1.2 and older
- Fixed in
- 4.1.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in WPFactory Advanced WooCommerce Product Sales Reporting webd-woocommerce-advanced-reporting-statistics allows Retrieve Embedded Sensitive Data.This issue affects Advanced WooCommerce Product Sales Reporting: from n/a through <= 4.1.2.
critical 9.3 CVE-2025-31553 · published 2025-04-01
SQL injection in Advanced Reporting and Statistics for WooComme… (4.1.1 and older)
- Affected
- 4.1.1 and older
- Fixed in
- 4.1.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WPFactory Advanced WooCommerce Product Sales Reporting webd-woocommerce-advanced-reporting-statistics allows SQL Injection.This issue affects Advanced WooCommerce Product Sales Reporting: from n/a through <= 4.1.1.
Recent activity
- 2026-04-27 — closed on wordpress.org (Guideline Violation).
- 2026-03-25 — SQL injection disclosed (CVE-2026-24993), fixed in 4.1.4.
- 2026-02-03 — Information disclosure disclosed (CVE-2026-24992), fixed in 4.1.3.
- 2025-04-01 — SQL injection disclosed (CVE-2025-31553), fixed in 4.1.2.
Get an email when Advanced Reporting and Statistics for WooComme… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Advanced Reporting and Statistics for WooComme… (webd-woocommerce-advanced-reporting-statistics) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/webd-woocommerce-advanced-reporting-statistics (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/webd-woocommerce-advanced-reporting-statistics"><img src="https://laskyr.com/plugins/webd-woocommerce-advanced-reporting-statistics/badge.svg" alt="Advanced Reporting and Statistics for WooComme… vulnerability status"></a>