Skip to content
Laskyr

Plugins · webcam-2way-videochat · data as of 2026-11-04

Is 2Way VideoCalls and Random Chat safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.1.10)

As of 2026-11-04. 2 issues are on record for older versions; version 6.1.6 or newer fixes all of them that state a fix.

Latest version
6.1.10
Last updated
2026-11-02
Active installs
10+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Add private 1-to-1 video call rooms and random video chat to WordPress with browser-based WebRTC and shareable room links. — by videowhisper

What to do

  1. Update to the latest version (6.1.10). Anything older than 6.1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get webcam-2way-videochat --field=version shows what you run; wp plugin update webcam-2way-videochat updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-110883 · published 2026-10-18

Authentication bypass in 2Way VideoCalls and Random Chat (6.1.5 and older)

Affected
6.1.5 and older
Fixed in
6.1.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authentication Bypass by Primary Weakness vulnerability in VideoWhisper.com 2Way VideoCalls and Random Chat webcam-2way-videochat allows Authentication Abuse.This issue affects 2Way VideoCalls and Random Chat: from n/a through 6.1.5.

NVD CVE-2026-110883Patchstack advisory

medium 6.1 CVE-2021-34656 · published 2021-08-16

Reflected cross-site scripting (XSS) in 2Way VideoCalls and Random Chat (5.2.7 to 5.2.7)

Affected
5.2.7 to 5.2.7
Fixed in
5.2.8 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The 2Way VideoCalls and Random Chat - HTML5 Webcam Videochat WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the `vws_notice` function found in the ~/inc/requirements.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 5.2.7.

NVD CVE-2021-34656Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
2Way VideoCalls and Random Chat vulnerability status badge
<a href="https://laskyr.com/plugins/webcam-2way-videochat"><img src="https://laskyr.com/plugins/webcam-2way-videochat/badge.svg" alt="2Way VideoCalls and Random Chat vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit