Plugins · webcake · data as of 2026-11-04
Is Webcake safe? Known vulnerabilities and latest version
- Latest version
- 1.2
- Last updated
- 2025-12-04
- Active installs
- 300+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.7.11 · PHP 5.6+
Webcake Page Builder for Wordpress. Use full feature from Webcake service. — by huyme
What to do
- Update to the latest version (1.2). Anything older than 1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get webcake --field=version shows what you run; wp plugin update webcake updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-12165 · published 2025-12-05
Missing authorization check in Webcake (1.1 and older)
- Affected
- 1.1 and older
- Fixed in
- 1.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Webcake – Landing Page Builder plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'webcake_save_config' AJAX endpoint in all versions up to, and including, 1.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify the plugin's settings.
NVD CVE-2025-12165Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2025-12-04 — latest release on wordpress.org (1.2).
- 2025-12-05 — Missing authorization check disclosed (CVE-2025-12165), fixed in 1.2.
Get an email when Webcake has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Webcake (webcake) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/webcake (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/webcake"><img src="https://laskyr.com/plugins/webcake/badge.svg" alt="Webcake vulnerability status"></a>