Plugins · weaver-for-bbpress · data as of 2026-11-04
Is Turnkey bbPress by WeaverTheme safe? Known vulnerabilities and latest version
- Latest version
- 1.8
- Last updated
- 2026-08-03
- Active installs
- 300+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.2+
At last! Turnkey bbPress. Beautiful bbPress styles. Essential layout and user/admin usability options. No CSS or PHP coding required. — by wpweaver
What to do
- Update to the latest version (1.8). Anything older than 1.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get weaver-for-bbpress --field=version shows what you run; wp plugin update weaver-for-bbpress updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.6 CVE-2026-10035 · published 2026-08-16
PHP object injection in Turnkey bbPress by WeaverTheme (1.7.1 and older)
- Affected
- 1.7.1 and older
- Fixed in
- 1.8 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Turnkey bbPress by WeaverTheme plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.7.1 via deserialization of untrusted input in the wvrbbp_set_to_serialized_values() function (reached through the wvrbbp_save_restore() settings-restore handler). The function reads the raw contents of an administrator-uploaded file and passes them directly to unserialize() without any validation. This makes it possible for authenticated attackers, with administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable plugin itself; however, if a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
NVD CVE-2026-10035Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2024-12221 · published 2025-01-04
Reflected cross-site scripting (XSS) in Turnkey bbPress by WeaverTheme (1.6.3 and older)
- Affected
- 1.6.3 and older
- Fixed in
- 1.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Turnkey bbPress by WeaverTheme plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘_wpnonce’ parameter in all versions up to, and including, 1.6.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-12221Wordfence advisoryCode change (fix)wordpress.org
Recent activity
- 2026-08-03 — latest release on wordpress.org (1.8).
- 2026-08-16 — PHP object injection disclosed (CVE-2026-10035), fixed in 1.8.
- 2025-01-04 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-12221), fixed in 1.7.
Get an email when Turnkey bbPress by WeaverTheme has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Turnkey bbPress by WeaverTheme (weaver-for-bbpress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by wpweaver (3 tracked)
Types found in this plugin: PHP object injection (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/weaver-for-bbpress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/weaver-for-bbpress"><img src="https://laskyr.com/plugins/weaver-for-bbpress/badge.svg" alt="Turnkey bbPress by WeaverTheme vulnerability status"></a>