Plugins · wcfm-marketplace-rest-api · data as of 2026-11-04
Is WCFM safe? Known vulnerabilities and latest version
- Latest version
- 1.6.3
- Last updated
- 2025-04-06
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 6.7.11 · PHP 7.4+
REST API for the most featured and powerful multi vendor plugin for your WooCommerce Multi-vendor Marketplace. — by WC Lovers
What to do
- There is no fixed version yet. If you can live without WCFM for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get wcfm-marketplace-rest-api --field=version shows what you run; wp plugin update wcfm-marketplace-rest-api updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 affects latest 1.6.3 CVE-2026-39794 · published 2026-10-06
Missing authorization check in WCFM (1.6.3 and older)
- Affected
- 1.6.3 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in WooCommerce Multivendor Marketplace – REST API <= 1.6.3 versions.
medium 6.5 CVE-2025-1311 · published 2025-03-22
SQL injection in WCFM (1.6.2 and older)
- Affected
- 1.6.2 and older
- Fixed in
- 1.6.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WooCommerce Multivendor Marketplace – REST API plugin for WordPress is vulnerable to SQL Injection via the 'id' parameter in the update_delivery_status() function in all versions up to, and including, 1.6.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2025-1311Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 5.4 CVE-2023-2275 · published 2023-06-09
Missing authorization check in WCFM (1.5.3 and older)
- Affected
- 1.5.3 and older
- Fixed in
- 1.6.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WooCommerce Multivendor Marketplace – REST API plugin for WordPress is vulnerable to unauthorized access of data and addition of data due to a missing capability check on the 'get_item', 'get_order_notes' and 'add_order_note' functions in versions up to, and including, 1.5.3. This makes it possible for authenticated attackers with subscriber privileges or above, to view the order details and order notes, and add order notes.
NVD CVE-2023-2275Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2025-04-06 — latest release on wordpress.org (1.6.3).
- 2026-10-06 — Missing authorization check disclosed (CVE-2026-39794), no fix listed yet.
- 2025-03-22 — SQL injection disclosed (CVE-2025-1311), fixed in 1.6.3.
- 2023-06-09 — Missing authorization check disclosed (CVE-2023-2275), fixed in 1.6.0.
Get an email when WCFM has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WCFM (wcfm-marketplace-rest-api) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WC Lovers (4 tracked)
Types found in this plugin: Missing authorization (2) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wcfm-marketplace-rest-api (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wcfm-marketplace-rest-api"><img src="https://laskyr.com/plugins/wcfm-marketplace-rest-api/badge.svg" alt="WCFM vulnerability status"></a>