Plugins · wcboost-products-compare · data as of 2026-11-04
Is WCBoost safe? Known vulnerabilities and latest version
- Latest version
- 1.1.2
- Last updated
- 2026-09-14
- Active installs
- 30,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
Enhance your WooCommerce store with WCBoost - Products Compare, enabling customers to easily compare products and make informed decisions. — by WCBoost
What to do
- Update to the latest version (1.1.2). Anything older than 1.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wcboost-products-compare --field=version shows what you run; wp plugin update wcboost-products-compare updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-57633 · published 2026-06-26
Information disclosure in WCBoost (1.1.0 and older)
- Affected
- 1.1.0 and older
- Fixed in
- 1.1.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Sensitive Data Exposure in WCBoost – Products Compare <= 1.1.0 versions.
Recent activity
- 2026-09-14 — latest release on wordpress.org (1.1.2).
- 2026-06-26 — Information disclosure disclosed (CVE-2026-57633), fixed in 1.1.1.
Get an email when WCBoost has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WCBoost (wcboost-products-compare) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wcboost-products-compare (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wcboost-products-compare"><img src="https://laskyr.com/plugins/wcboost-products-compare/badge.svg" alt="WCBoost vulnerability status"></a>