Skip to content
Laskyr

Plugins · wc-support-system · data as of 2026-11-04

Is ilGhera Support System for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.7)

As of 2026-11-04. 4 issues are on record for older versions; version 1.3.1 or newer fixes all of them that state a fix.

Latest version
1.3.7
Last updated
2026-10-15
Active installs
50+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

Give support to your WooComerce customers with this fast and easy to use ticket system. — by ilGhera

What to do

  1. Update to the latest version (1.3.7). Anything older than 1.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wc-support-system --field=version shows what you run; wp plugin update wc-support-system updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-14033 · published 2026-05-13

Missing authorization check in ilGhera Support System for WooCommerce (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ilGhera Support System for WooCommerce plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'get_ticket_content_callback' function in all versions up to, and including, 1.3.0. This makes it possible for unauthenticated attackers to view any support ticket content, including sensitive customer information and private communications, by providing a ticket ID.

NVD CVE-2025-14033Wordfence advisoryPlugin source

medium 5.3 CVE-2025-14034 · published 2026-01-06

Missing authorization check in ilGhera Support System for WooCommerce (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.2.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ilGhera Support System for WooCommerce plugin for WordPress is vulnerable to unauthorized modification and loss of data due to a missing capability check on the 'delete_single_ticket_callback' and 'change_ticket_status_callback' functions in all versions up to, and including, 1.2.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary support tickets and modify their status.

NVD CVE-2025-14034Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2023-41686 · published 2024-12-13

Cross-site request forgery (CSRF) in ilGhera Support System for WooCommerce (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.2.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in ilGhera Woocommerce Support System allows Cross Site Request Forgery.This issue affects Woocommerce Support System: from n/a through 1.2.2.

NVD CVE-2023-41686Patchstack advisory

critical 9.8 CVE-2023-41685 · published 2023-11-06

SQL injection in ilGhera Support System for WooCommerce (1.2.1 and older)

Affected
1.2.1 and older
Fixed in
1.2.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in ilGhera Woocommerce Support System allows SQL Injection.This issue affects Woocommerce Support System: from n/a through 1.2.1.

NVD CVE-2023-41685Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ilGhera Support System for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/wc-support-system"><img src="https://laskyr.com/plugins/wc-support-system/badge.svg" alt="ilGhera Support System for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit