Skip to content
Laskyr

Plugins · wc-peach-payments-gateway · data as of 2026-11-04

Is Peach Payments Gateway safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.0)

As of 2026-11-04. 3 issues are on record for older versions; version 4.0.3 or newer fixes all of them that state a fix.

Latest version
4.1.0
Last updated
2026-10-20
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

A payment gateway integration between WooCommerce and Peach Payments. — by peachpayments

What to do

  1. Update to the latest version (4.1.0). Anything older than 4.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wc-peach-payments-gateway --field=version shows what you run; wp plugin update wc-peach-payments-gateway updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-57408 · published 2026-07-13

Missing authorization check in Peach Payments Gateway (4.0.2 and older)

Affected
4.0.2 and older
Fixed in
4.0.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in peachpayments Peach Payments Gateway wc-peach-payments-gateway allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Peach Payments Gateway: from n/a through <= 4.0.2.

NVD CVE-2026-57408Patchstack advisory

medium 6.5 CVE-2025-67942 · published 2026-01-22

Missing authorization check in Peach Payments Gateway (3.3.6 and older)

Affected
3.3.6 and older
Fixed in
3.3.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in peachpayments Peach Payments Gateway wc-peach-payments-gateway allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Peach Payments Gateway: from n/a through <= 3.3.6.

NVD CVE-2025-67942Patchstack advisory

medium 5.4 CVE-2024-25922 · published 2024-04-11

Missing authorization check in Peach Payments Gateway (3.1.9 and older)

Affected
3.1.9 and older
Fixed in
3.2.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Peach Payments Peach Payments Gateway.This issue affects Peach Payments Gateway: from n/a through 3.1.9.

NVD CVE-2024-25922Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Peach Payments Gateway vulnerability status badge
<a href="https://laskyr.com/plugins/wc-peach-payments-gateway"><img src="https://laskyr.com/plugins/wc-peach-payments-gateway/badge.svg" alt="Peach Payments Gateway vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit