Plugins · wc-fields-factory · data as of 2026-11-04
Is WC Fields Factory safe? Known vulnerabilities and latest version
- Latest version
- 4.1.12
- Last updated
- 2026-09-17
- Active installs
- 7,000+
- Known issues on record
- 4
- Unpatched in latest
- 1
- Tested up to WP
- 7.1.4
Sell your products with personalised options. Add custom fields to your products, variations, checkout, order and your admin screens. — by Saravana Kumar K
What to do
- There is no fixed version yet. If you can live without WC Fields Factory for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get wc-fields-factory --field=version shows what you run; wp plugin update wc-fields-factory updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 4.1.12 CVE-2026-39727 · published 2026-10-06
Cross-site scripting (XSS) in WC Fields Factory (4.1.12 and older)
- Affected
- 4.1.12 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Cross Site Scripting (XSS) in WC Fields Factory <= 4.1.12 versions.
low 3.3 CVE-2026-93507 · published 2026-09-23
Missing authorization check in WC Fields Factory (older than 4.1.11)
- Affected
- older than 4.1.11
- Fixed in
- 4.1.11
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WC Fields Factory WordPress plugin before 4.1.11 does not properly restrict access to, or verify a nonce for, a post-cloning action, allowing Contributor-level users and above to duplicate arbitrary posts of any type or status, including other users' private or draft content, and gain read access to the resulting copy.
high 8.1 CVE-2026-93508 · published 2026-09-23
Missing authorization check in WC Fields Factory (older than 4.1.11)
- Affected
- older than 4.1.11
- Fixed in
- 4.1.11
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WC Fields Factory WordPress plugin before 4.1.11 does not properly restrict access to its field-management AJAX action, allowing authenticated users with Subscriber-level access and above to create, modify and delete arbitrary post meta on any post, including WooCommerce products, regardless of ownership, and to manipulate stored pricing rules on a product to reduce its checkout price.
high 7.2 CVE-2023-0277 · published 2023-04-17
SQL injection in WC Fields Factory (4.1.5 and older)
- Affected
- 4.1.5 and older
- Fixed in
- 4.1.6 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WC Fields Factory WordPress plugin through 4.1.5 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin
Recent activity
- 2026-09-17 — latest release on wordpress.org (4.1.12).
- 2026-10-06 — Cross-site scripting (XSS) disclosed (CVE-2026-39727), no fix listed yet.
- 2026-09-23 — Missing authorization check disclosed (CVE-2026-93507), fixed in 4.1.11.
- 2026-09-23 — Missing authorization check disclosed (CVE-2026-93508), fixed in 4.1.11.
Get an email when WC Fields Factory has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WC Fields Factory (wc-fields-factory) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wc-fields-factory (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wc-fields-factory"><img src="https://laskyr.com/plugins/wc-fields-factory/badge.svg" alt="WC Fields Factory vulnerability status"></a>