Skip to content
Laskyr

Plugins · wc-blacklist-manager · data as of 2026-11-04

Is Blacklist Manager safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.2 or newer fixes all of them that state a fix.

Latest version
2.4.1
Last updated
2026-11-03
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Block risky WooCommerce orders, spam signups, and form submissions with blacklist rules plus built-in checkout email verification. — by YoOhw Studio

What to do

  1. Update to the latest version (2.4.1). Anything older than 2.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wc-blacklist-manager --field=version shows what you run; wp plugin update wc-blacklist-manager updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-96838 · published 2026-09-30

Cross-site request forgery (CSRF) in Blacklist Manager (2.3.1 and older)

Affected
2.3.1 and older
Fixed in
2.3.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in Blacklist Manager &#8211; WooCommerce Anti-Fraud, Blacklist &amp; Checkout Verification <= 2.3.1 versions.

NVD CVE-2026-96838Patchstack advisory

medium 5.4 CVE-2026-88828 · published 2026-09-28

Authentication bypass in Blacklist Manager (1.3.0 up to (not including) 2.3.2)

Affected
1.3.0 up to (not including) 2.3.2
Fixed in
2.3.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Blacklist Manager for WooCommerce WordPress plugin from 1.3.0 to 2.3.1 does not enforce its user blocking on every authentication path, allowing the holder of an account the site owner has blocked to keep authenticating with that account's privileges, without the block being enforced or recorded.

NVD CVE-2026-88828WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Blacklist Manager vulnerability status badge
<a href="https://laskyr.com/plugins/wc-blacklist-manager"><img src="https://laskyr.com/plugins/wc-blacklist-manager/badge.svg" alt="Blacklist Manager vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit