Skip to content
Laskyr

Plugins · wavesurfer-wp · data as of 2026-11-04

Is WaveSurfer-WP safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.8.4)

As of 2026-11-04. 1 issue is on record for older versions; version 2.8.4 or newer fixes all of them that state a fix.

Latest version
2.8.4
Last updated
2026-02-04
Active installs
400+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
5.4.25

Customizable HTML5 Audio controller with waveform preview (mixed or split channels), using WordPress native audio and playlist shortcode. — by X-Raym

What to do

  1. Update to the latest version (2.8.4). Anything older than 2.8.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wavesurfer-wp --field=version shows what you run; wp plugin update wavesurfer-wp updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-1909 · published 2026-02-06

Stored cross-site scripting (XSS) in WaveSurfer-WP (2.8.3 and older)

Affected
2.8.3 and older
Fixed in
2.8.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WaveSurfer-WP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's audio shortcode in all versions up to, and including, 2.8.3 due to insufficient input sanitization and output escaping on the 'src' attribute. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1909Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WaveSurfer-WP vulnerability status badge
<a href="https://laskyr.com/plugins/wavesurfer-wp"><img src="https://laskyr.com/plugins/wavesurfer-wp/badge.svg" alt="WaveSurfer-WP vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit