Skip to content
Laskyr

Plugins · watchtowerhq · data as of 2026-11-04

Is WatchTowerHQ safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.7)

As of 2026-11-04. 5 issues are on record for older versions; version 3.16.1 or newer fixes all of them that state a fix.

Latest version
4.0.7
Last updated
2026-06-24
Active installs
100+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

The WatchTowerHQ WordPress plugin allows us to monitor, backup, upgrade, and manage your site! — by watchtowerhq

What to do

  1. Update to the latest version (4.0.7). Anything older than 3.16.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get watchtowerhq --field=version shows what you run; wp plugin update watchtowerhq updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2025-13972 · published 2025-12-12

Path traversal / file read in WatchTowerHQ (3.16.0 and older)

Affected
3.16.0 and older
Fixed in
3.16.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WatchTowerHQ plugin for WordPress is vulnerable to arbitrary file read via the 'wht_download_big_object_origin' parameter in all versions up to, and including, 3.16.0. This is due to insufficient path validation in the handle_big_object_download_request function. This makes it possible for authenticated attackers, with administrator-level access and a valid access token, to read arbitrary files on the server, which can contain sensitive information such as database credentials and authentication keys.

NVD CVE-2025-13972Wordfence advisoryPlugin source

critical 9.8 CVE-2024-9933 · published 2024-10-26

Authentication bypass in WatchTowerHQ (3.10.1 and older)

Affected
3.10.1 and older
Fixed in
3.10.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WatchTowerHQ plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.10.1. This is due to the 'watchtower_ota_token' default value is empty, and the not empty check is missing in the 'Password_Less_Access::login' function. This makes it possible for unauthenticated attackers to log in to the WatchTowerHQ client administrator user.

NVD CVE-2024-9933Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2023-25701 · published 2024-05-17

Privilege escalation in WatchTowerHQ (3.6.16 and older)

Affected
3.6.16 and older
Fixed in
3.6.17
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Privilege Management vulnerability in WhatArmy WatchTowerHQ allows Privilege Escalation.This issue affects WatchTowerHQ: from n/a through 3.6.16.

NVD CVE-2023-25701Patchstack advisory

high 7.5 CVE-2022-44583 · published 2022-11-18

Security issue in WatchTowerHQ (3.6.15 and older)

Affected
3.6.15 and older
Fixed in
3.6.16 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Arbitrary File Download vulnerability in WatchTowerHQ plugin <= 3.6.15 on WordPress.

NVD CVE-2022-44583Patchstack advisorywordpress.org

critical 9.1 CVE-2022-44584 · published 2022-11-18

Arbitrary file deletion in WatchTowerHQ (3.6.15 and older)

Affected
3.6.15 and older
Fixed in
3.6.16 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Arbitrary File Deletion vulnerability in WatchTowerHQ plugin <= 3.6.15 on WordPress.

NVD CVE-2022-44584Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WatchTowerHQ vulnerability status badge
<a href="https://laskyr.com/plugins/watchtowerhq"><img src="https://laskyr.com/plugins/watchtowerhq/badge.svg" alt="WatchTowerHQ vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit