Plugins · wappointment · data as of 2026-11-04
Is Appointment Bookings for Zoom GoogleMeet and m… safe? Known vulnerabilities and latest version
- Latest version
- 2.7.7
- Last updated
- 2026-05-24
- Active installs
- 1,000+
- Known issues on record
- 5
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8 · PHP 7.4+
Get clients to quickly book a meeting with you by Zoom, GoogleMeet, phone or at your office — by Wappointment team
What to do
- There is no fixed version yet. If you can live without Appointment Bookings for Zoom GoogleMeet and m… for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get wappointment --field=version shows what you run; wp plugin update wappointment updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 affects latest 2.7.7 CVE-2026-39756 · published 2026-10-06
Missing authorization check in Appointment Bookings for Zoom GoogleMeet and m… (2.7.7 and older)
- Affected
- 2.7.7 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Insecure Direct Object References (IDOR) in Wappointment <= 2.7.7 versions.
medium 5.3 CVE-2026-9188 · published 2026-07-02
Missing authorization check in Appointment Bookings for Zoom GoogleMeet and m… (2.7.6 and older)
- Affected
- 2.7.6 and older
- Fixed in
- 2.7.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Appointment Bookings for Zoom GoogleMeet and more – Wappointment plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to and including 2.7.6 via the `appointmentkey` parameter due to the appointment `edit_key` — the sole authorization token consumed by `tryCancel()` — being generated as a predictable, unsalted MD5 hash of only `client_id` (a sequential integer), `start_at` (a publicly observable appointment timestamp), and `staff_id` (a small enumerable integer), with no secret salt or random component, and the unauthenticated cancellation and rescheduling REST endpoints performing no ownership or identity verification beyond matching this reconstructible key. This makes it possible for unauthenticated attackers to compute valid `edit_key` values for appointments belonging to other users and cancel or reschedule those appointments arbitrarily. Exploitation requires the `allow_cancellation` or `allow_rescheduling` setting to be enabled on the site, both of which are common configurations for active booking deployments; an attacker can obtain the inputs needed to reconstruct a victim's key by booking their own appointment to observe their sequential `client_id` and correlating publicly visible appointment times and enumerable staff identifiers.
NVD CVE-2026-9188Wordfence advisoryCode change (fix)Plugin source
medium 5.3 CVE-2025-68575 · published 2025-12-24
Missing authorization check in Appointment Bookings for Zoom GoogleMeet and m… (2.7.6 and older)
- Affected
- 2.7.6 and older
- Fixed in
- 2.7.7 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Wappointment team Wappointment wappointment allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Wappointment: from n/a through <= 2.7.6.
medium 6.5 CVE-2025-67551 · published 2025-12-09
Stored cross-site scripting (XSS) in Appointment Bookings for Zoom GoogleMeet and m… (2.6.9 and older)
- Affected
- 2.6.9 and older
- Fixed in
- 2.7.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Wappointment team Wappointment wappointment allows Stored XSS.This issue affects Wappointment: from n/a through <= 2.6.9.
medium 4.4 CVE-2024-32454 · published 2024-04-15
Server-side request forgery (SSRF) in Appointment Bookings for Zoom GoogleMeet and m… (2.6.0 and older)
- Affected
- 2.6.0 and older
- Fixed in
- 2.6.1
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in Wappointment Appointment Bookings for Zoom GoogleMeet and more – Wappointment.This issue affects Appointment Bookings for Zoom GoogleMeet and more – Wappointment: from n/a through 2.6.0.
Recent activity
- 2026-05-24 — latest release on wordpress.org (2.7.7).
- 2026-10-06 — Missing authorization check disclosed (CVE-2026-39756), no fix listed yet.
- 2026-07-02 — Missing authorization check disclosed (CVE-2026-9188), fixed in 2.7.7.
- 2025-12-24 — Missing authorization check disclosed (CVE-2025-68575), fixed in 2.7.7.
Get an email when Appointment Bookings for Zoom GoogleMeet and m… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Appointment Bookings for Zoom GoogleMeet and m… (wappointment) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (3) · Cross-site scripting (XSS) (1) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wappointment (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wappointment"><img src="https://laskyr.com/plugins/wappointment/badge.svg" alt="Appointment Bookings for Zoom GoogleMeet and m… vulnerability status"></a>