Skip to content
Laskyr

Plugins · walker-core · data as of 2026-11-04

Is Walker Core safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.18)

As of 2026-11-04. 1 issue is on record for older versions; version 1.3.18 or newer fixes all of them that state a fix.

Latest version
1.3.18
Last updated
2025-11-27
Active installs
700+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.3+

Walker Core is the companion plugin for WalkerWP Themes, which provides core functionality and custom post type for the themes. — by WalkerWP

What to do

  1. Update to the latest version (1.3.18). Anything older than 1.3.18 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get walker-core --field=version shows what you run; wp plugin update walker-core updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-67552 · published 2025-12-09

Cross-site scripting (XSS) in Walker Core (1.3.17 and older)

Affected
1.3.17 and older
Fixed in
1.3.18
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WalkerWP Walker Core walker-core allows DOM-Based XSS.This issue affects Walker Core: from n/a through <= 1.3.17.

NVD CVE-2025-67552Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Walker Core vulnerability status badge
<a href="https://laskyr.com/plugins/walker-core"><img src="https://laskyr.com/plugins/walker-core/badge.svg" alt="Walker Core vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit