Plugins · waitlist-woocommerce · data as of 2026-11-04
Is Waitlist Woocommerce ( Back in stock notifier ) safe? Known vulnerabilities and latest version
- Latest version
- 2.9.3
- Last updated
- 2026-11-02
- Active installs
- 4,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Build a waiting list for your products and notify customers by email based on product availability. — by xootix
What to do
- Update to the latest version (2.9.3). Anything older than 2.9.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get waitlist-woocommerce --field=version shows what you run; wp plugin update waitlist-woocommerce updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-77188 · published 2026-10-28
Stored cross-site scripting (XSS) in Waitlist Woocommerce ( Back in stock notifier ) (2.9.1 and older)
- Affected
- 2.9.1 and older
- Fixed in
- 2.9.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Waitlist Woocommerce ( Back in stock notifier ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'type' Shortcode Attribute in all versions up to, and including, 2.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The wp_kses_post filter applied on contributor post save does not prevent this vulnerability because shortcode attribute values are not HTML and pass through kses unchanged; the payload is materialized only at render time when the shortcode is expanded.
NVD CVE-2026-77188Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2026-114701 · published 2026-10-22
Stored cross-site scripting (XSS) in Waitlist Woocommerce ( Back in stock notifier ) (2.9.1 and older)
- Affected
- 2.9.1 and older
- Fixed in
- 2.9.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in xootix Waitlist Woocommerce ( Back in stock notifier ) waitlist-woocommerce allows Stored XSS.This issue affects Waitlist Woocommerce ( Back in stock notifier ): from n/a through 2.9.1.
medium 4.3 CVE-2024-43134 · published 2024-11-01
Missing authorization check in Waitlist Woocommerce ( Back in stock notifier ) (2.6 and older)
- Affected
- 2.6 and older
- Fixed in
- 2.6.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in xootix Waitlist Woocommerce ( Back in stock notifier ) allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Waitlist Woocommerce ( Back in stock notifier ): from n/a through 2.6.
medium 6.1 CVE-2024-8724 · published 2024-09-14
Reflected cross-site scripting (XSS) in Waitlist Woocommerce ( Back in stock notifier ) (2.7.5 and older)
- Affected
- 2.7.5 and older
- Fixed in
- 2.7.6 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Waitlist Woocommerce ( Back in stock notifier ) plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 2.7.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2024-8724Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2022-0215 · published 2022-01-18
Cross-site request forgery (CSRF) in Waitlist Woocommerce ( Back in stock notifier ) (2.5.1 to 2.5.1)
- Affected
- 2.5.1 to 2.5.1
- Fixed in
- 2.5.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Login/Signup Popup, Waitlist Woocommerce ( Back in stock notifier ), and Side Cart Woocommerce (Ajax) WordPress plugins by XootiX are vulnerable to Cross-Site Request Forgery via the save_settings function found in the ~/includes/xoo-framework/admin/class-xoo-admin-settings.php file which makes it possible for attackers to update arbitrary options on a site that can be used to create an administrative user account and grant full privileged access to a compromised site. This affects versions <= 2.2 in Login/Signup Popup, versions <= 2.5.1 in Waitlist Woocommerce ( Back in stock notifier ), and versions <= 2.0 in Side Cart Woocommerce (Ajax).
NVD CVE-2022-0215Wordfence advisoryWordfence advisoryPlugin source
Recent activity
- 2026-11-02 — latest release on wordpress.org (2.9.3).
- 2026-10-28 — Stored cross-site scripting (XSS) disclosed (CVE-2026-77188), fixed in 2.9.2.
- 2026-10-22 — Stored cross-site scripting (XSS) disclosed (CVE-2026-114701), fixed in 2.9.2.
- 2024-11-01 — Missing authorization check disclosed (CVE-2024-43134), fixed in 2.6.1.
Get an email when Waitlist Woocommerce ( Back in stock notifier ) has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Waitlist Woocommerce ( Back in stock notifier ) (waitlist-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by xootix (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3) · Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/waitlist-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/waitlist-woocommerce"><img src="https://laskyr.com/plugins/waitlist-woocommerce/badge.svg" alt="Waitlist Woocommerce ( Back in stock notifier ) vulnerability status"></a>