Skip to content
Laskyr

Plugins · w4-post-list · data as of 2026-11-04

Is W4 Post List safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.9)

As of 2026-11-04. 5 issues are on record for older versions; version 3.0.7 or newer fixes all of them that state a fix.

Latest version
3.0.9
Last updated
2026-10-02
Active installs
3,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Build lists the Query Loop can't: posts grouped by year, category or author, term lists and user directories — via block, shortcode or widget. — by Shazzad Hossain Khan

What to do

  1. Update to the latest version (3.0.9). Anything older than 3.0.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get w4-post-list --field=version shows what you run; wp plugin update w4-post-list updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.6 CVE-2026-96826 · published 2026-09-23

SQL injection in W4 Post List (3.0.6 and older)

Affected
3.0.6 and older
Fixed in
3.0.7
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Shazzad Hossain Khan W4 Post List allows Blind SQL Injection. This issue affects W4 Post List: from n/a through 3.0.6.

NVD CVE-2026-96826Patchstack advisory

medium 5.4 CVE-2023-27413 · published 2023-06-22

Stored cross-site scripting (XSS) in W4 Post List (2.4.4 and older)

Affected
2.4.4 and older
Fixed in
2.4.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Shazzad Hossain Khan W4 Post List plugin <= 2.4.4 versions.

NVD CVE-2023-27413Patchstack advisory

medium 6.5 CVE-2023-1371 · published 2023-04-17

Missing authorization check in W4 Post List (older than 2.4.6)

Affected
older than 2.4.6
Fixed in
2.4.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The W4 Post List WordPress plugin before 2.4.6 does not ensure that password protected posts can be accessed before displaying their content, which could allow any authenticated users to access them

NVD CVE-2023-1371WPScan advisory

medium 6.1 CVE-2023-1373 · published 2023-04-17

Reflected cross-site scripting (XSS) in W4 Post List (older than 2.4.6)

Affected
older than 2.4.6
Fixed in
2.4.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The W4 Post List WordPress plugin before 2.4.6 does not escape some URLs before outputting them in attributes, leading to Reflected Cross-Site Scripting

NVD CVE-2023-1373WPScan advisory

medium 5.4 CVE-2023-0374 · published 2023-04-17

Stored cross-site scripting (XSS) in W4 Post List (older than 2.4.6)

Affected
older than 2.4.6
Fixed in
2.4.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The W4 Post List WordPress plugin before 2.4.6 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

NVD CVE-2023-0374WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
W4 Post List vulnerability status badge
<a href="https://laskyr.com/plugins/w4-post-list"><img src="https://laskyr.com/plugins/w4-post-list/badge.svg" alt="W4 Post List vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit