Plugins · vk-google-job-posting-manager · data as of 2026-11-04
Is VK Google Job Posting Manager safe? Known vulnerabilities and latest version
- Latest version
- 1.4.0
- Last updated
- 2026-09-23
- Active installs
- 2,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
This plugin generates JSON-LD of your recruitment info which required to register Google Job Posting. — by Vektor,Inc.
What to do
- Update to the latest version (1.4.0). Anything older than 1.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get vk-google-job-posting-manager --field=version shows what you run; wp plugin update vk-google-job-posting-manager updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-100511 · published 2026-10-05
PHP object injection in VK Google Job Posting Manager (1.3.1 and older)
- Affected
- 1.3.1 and older
- Fixed in
- 1.3.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in Vektor Inc. VK Google Job Posting Manager vk-google-job-posting-manager allows Object Injection.This issue affects VK Google Job Posting Manager: from n/a through 1.3.1.
medium 6.4 CVE-2025-12836 · published 2026-01-24
Stored cross-site scripting (XSS) in VK Google Job Posting Manager (1.2.23 and older)
- Affected
- 1.2.23 and older
- Fixed in
- 1.2.24 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The VK Google Job Posting Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Job Description field in versions up to, and including, 1.2.23 due to insufficient input sanitization and output escaping on user-supplied attributes. This makes it possible for authenticated attackers with author-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-12836Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2025-68070 · published 2025-12-16
Stored cross-site scripting (XSS) in VK Google Job Posting Manager (1.2.22 and older)
- Affected
- 1.2.22 and older
- Fixed in
- 1.2.23
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Vektor,Inc. VK Google Job Posting Manager vk-google-job-posting-manager allows Stored XSS.This issue affects VK Google Job Posting Manager: from n/a through <= 1.2.22.
Recent activity
- 2026-09-23 — latest release on wordpress.org (1.4.0).
- 2026-10-05 — PHP object injection disclosed (CVE-2026-100511), fixed in 1.3.2.
- 2026-01-24 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12836), fixed in 1.2.24.
- 2025-12-16 — Stored cross-site scripting (XSS) disclosed (CVE-2025-68070), fixed in 1.2.23.
Get an email when VK Google Job Posting Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for VK Google Job Posting Manager (vk-google-job-posting-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Vektor,Inc. (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/vk-google-job-posting-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/vk-google-job-posting-manager"><img src="https://laskyr.com/plugins/vk-google-job-posting-manager/badge.svg" alt="VK Google Job Posting Manager vulnerability status"></a>