Skip to content
Laskyr

Plugins · vk-blocks · data as of 2026-11-04

Is VK Blocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.130.0)

As of 2026-11-04. 5 issues are on record for older versions; version 1.126.2 or newer fixes all of them that state a fix.

Latest version
1.130.0
Last updated
2026-11-02
Active installs
100,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

This is a plugin that extends Gutenberg's blocks. — by Vektor,Inc.

What to do

  1. Update to the latest version (1.130.0). Anything older than 1.126.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get vk-blocks --field=version shows what you run; wp plugin update vk-blocks updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-78087 · published 2026-10-15

Stored cross-site scripting (XSS) in VK Blocks (1.126.1 and older)

Affected
1.126.1 and older
Fixed in
1.126.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The VK Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Group Block 'linkToPost' Feature in all versions up to, and including, 1.126.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-78087Wordfence advisoryCode change (fix)

medium 4.3 CVE-2024-13635 · published 2025-03-07

Information disclosure in VK Blocks (1.94.2.2 and older)

Affected
1.94.2.2 and older
Fixed in
1.95.0.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The VK Blocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.94.2.2 via the page content block. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including the content of private posts and pages.

NVD CVE-2024-13635Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-5706 · published 2023-11-22

Stored cross-site scripting (XSS) in VK Blocks (1.63.0.1 and older)

Affected
1.63.0.1 and older
Fixed in
1.64.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The VK Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'vk-blocks/ancestor-page-list' block in all versions up to, and including, 1.63.0.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-5706Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2023-0583 · published 2023-06-03

Missing authorization check in VK Blocks (1.57.0.5 and older)

Affected
1.57.0.5 and older
Fixed in
1.57.1.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The VK Blocks plugin for WordPress is vulnerable to improper authorization via the REST 'update_vk_blocks_options' function in versions up to, and including, 1.57.0.5. This allows authenticated attackers, with contributor-level permissions or above, to change plugin settings including default icons.

NVD CVE-2023-0583Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2023-0584 · published 2023-06-03

Missing authorization check in VK Blocks (1.57.0.5 and older)

Affected
1.57.0.5 and older
Fixed in
1.57.1.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The VK Blocks plugin for WordPress is vulnerable to improper authorization via the REST 'update_options' function in versions up to, and including, 1.57.0.5. This allows authenticated attackers, with contributor-level permissions or above, to change the 'vk_font_awesome_version' option to an arbitrary value.

NVD CVE-2023-0584Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
VK Blocks vulnerability status badge
<a href="https://laskyr.com/plugins/vk-blocks"><img src="https://laskyr.com/plugins/vk-blocks/badge.svg" alt="VK Blocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit