Skip to content
Laskyr

Plugins · visual-portfolio · data as of 2026-11-04

Is Gallery by Visual Portfolio safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9.0)

As of 2026-11-04. 2 issues are on record for older versions; version 3.5.2 or newer fixes all of them that state a fix.

Latest version
3.9.0
Last updated
2026-10-24
Active installs
60,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.2 · PHP 8.3+

Build photo galleries, image galleries, and portfolio grids with gallery blocks. Masonry, lightbox, sliders, and filters included. — by nK

What to do

  1. Update to the latest version (3.9.0). Anything older than 3.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get visual-portfolio --field=version shows what you run; wp plugin update visual-portfolio updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-32537 · published 2026-03-25

File inclusion in Gallery by Visual Portfolio (3.5.1 and older)

Affected
3.5.1 and older
Fixed in
3.5.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
advisory text · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in nK Visual Portfolio, Photo Gallery & Post Grid visual-portfolio allows PHP Local File Inclusion.This issue affects Visual Portfolio, Photo Gallery & Post Grid: from n/a through <= 3.5.1.

NVD CVE-2026-32537Patchstack advisory

medium 6.4 CVE-2024-4363 · published 2024-05-15

Stored cross-site scripting (XSS) in Gallery by Visual Portfolio (3.3.2 and older)

Affected
3.3.2 and older
Fixed in
3.3.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Visual Portfolio, Photo Gallery & Post Grid plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘title_tag’ parameter in all versions up to, and including, 3.3.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4363Wordfence advisorywordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Gallery by Visual Portfolio vulnerability status badge
<a href="https://laskyr.com/plugins/visual-portfolio"><img src="https://laskyr.com/plugins/visual-portfolio/badge.svg" alt="Gallery by Visual Portfolio vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit