Skip to content
Laskyr

Plugins · visual-link-preview · data as of 2026-11-04

Is Visual Link Preview safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.2)

As of 2026-11-04. 6 issues are on record for older versions; version 2.4.2 or newer fixes all of them that state a fix.

Latest version
2.4.2
Last updated
2026-08-19
Active installs
10,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4

Display a fully customizable visual link preview for any internal or external link. — by Brecht

What to do

  1. Update to the latest version (2.4.2). Anything older than 2.4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get visual-link-preview --field=version shows what you run; wp plugin update visual-link-preview updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.4 CVE-2026-54821 · published 2026-06-25

Information disclosure in Visual Link Preview (2.3.1 and older)

Affected
2.3.1 and older
Fixed in
2.4.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Sensitive Data Exposure in Visual Link Preview <= 2.3.1 versions.

NVD CVE-2026-54821Patchstack advisory

medium 6.5 CVE-2026-48878 · published 2026-06-15

Information disclosure in Visual Link Preview (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.4.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Sensitive Data Exposure in Visual Link Preview <= 2.4.1 versions.

NVD CVE-2026-48878Patchstack advisory

medium 6.0 CVE-2026-39670 · published 2026-04-08

Server-side request forgery (SSRF) in Visual Link Preview (2.3.0 and older)

Affected
2.3.0 and older
Fixed in
2.3.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Brecht Visual Link Preview visual-link-preview allows Server Side Request Forgery.This issue affects Visual Link Preview: from n/a through <= 2.3.0.

NVD CVE-2026-39670Patchstack advisory

medium 6.5 CVE-2026-24984 · published 2026-02-03

Missing authorization check in Visual Link Preview (2.2.9 and older)

Affected
2.2.9 and older
Fixed in
2.3.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Brecht Visual Link Preview visual-link-preview allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Visual Link Preview: from n/a through <= 2.2.9.

NVD CVE-2026-24984Patchstack advisory

medium 6.4 CVE-2025-11987 · published 2025-11-05

Stored cross-site scripting (XSS) in Visual Link Preview (2.2.7 and older)

Affected
2.2.7 and older
Fixed in
2.2.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Visual Link Preview plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's visual-link-preview shortcode in versions up to, and including, 2.2.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-11987Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2021-24635 · published 2021-09-20

Cross-site request forgery (CSRF) in Visual Link Preview (older than 2.2.3)

Affected
older than 2.2.3
Fixed in
2.2.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
NVD analysis · score by NVD
Details from the advisory

The Visual Link Preview WordPress plugin before 2.2.3 does not enforce authorisation on several AJAX actions and has the CSRF nonce displayed for all authenticated users, allowing any authenticated user (such as subscriber) to call them and 1) Get and search through title and content of Draft post, 2) Get title of a password-protected post as well as 3) Upload an image from an URL

NVD CVE-2021-24635WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Visual Link Preview vulnerability status badge
<a href="https://laskyr.com/plugins/visual-link-preview"><img src="https://laskyr.com/plugins/visual-link-preview/badge.svg" alt="Visual Link Preview vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit