Skip to content
Laskyr

Plugins · visa-acceptance-solutions · data as of 2026-11-04

Is Visa Acceptance Solutions safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.0)

As of 2026-11-04. 1 issue is on record for older versions; version 2.1.1 or newer fixes all of them that state a fix.

Latest version
3.0.0
Last updated
2026-10-28
Active installs
10,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2.0+

Accept payments securely with Visa Acceptance Solutions. — by Visa Acceptance Solutions

What to do

  1. Update to the latest version (3.0.0). Anything older than 2.1.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get visa-acceptance-solutions --field=version shows what you run; wp plugin update visa-acceptance-solutions updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-3461 · published 2026-04-15

Authentication bypass in Visa Acceptance Solutions (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.1.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Visa Acceptance Solutions plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 2.1.0. This is due to the `express_pay_product_page_pay_for_order()` function logging users in based solely on a user-supplied billing email address during guest checkout for subscription products, without verifying email ownership, requiring a password, or validating a one-time token. This makes it possible for unauthenticated attackers to log in as any existing user, including administrators, by providing the target user's email address in the billing_details parameter, resulting in complete account takeover and site compromise.

NVD CVE-2026-3461Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Visa Acceptance Solutions vulnerability status badge
<a href="https://laskyr.com/plugins/visa-acceptance-solutions"><img src="https://laskyr.com/plugins/visa-acceptance-solutions/badge.svg" alt="Visa Acceptance Solutions vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit