Skip to content
Laskyr

Plugins · virtue-toolkit · data as of 2026-11-04

Is Virtue/Ascend/Pinnacle Toolkit safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.9.12.2)

As of 2026-11-04. 2 issues are on record for older versions; version 4.9.12.2 or newer fixes all of them that state a fix.

Latest version
4.9.12.2
Last updated
2026-09-24
Active installs
30,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Custom Portfolio and Shortcode functionality for free Virtue, Ascend, and Pinnacle WordPress themes — by Nexcess

What to do

  1. Update to the latest version (4.9.12.2). Anything older than 4.9.12.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get virtue-toolkit --field=version shows what you run; wp plugin update virtue-toolkit updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-97266 · published 2026-09-30

Cross-site scripting (XSS) in Virtue/Ascend/Pinnacle Toolkit (4.9.12.1 and older)

Affected
4.9.12.1 and older
Fixed in
4.9.12.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Virtue/Ascend/Pinnacle Toolkit <= 4.9.12.1 versions.

NVD CVE-2026-97266Patchstack advisory

medium 6.5 CVE-2026-65473 · published 2026-07-23

Cross-site scripting (XSS) in Virtue/Ascend/Pinnacle Toolkit (4.9.12 and older)

Affected
4.9.12 and older
Fixed in
4.9.12.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor Cross Site Scripting (XSS) in Virtue/Ascend/Pinnacle Toolkit <= 4.9.12 versions.

NVD CVE-2026-65473Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Virtue/Ascend/Pinnacle Toolkit vulnerability status badge
<a href="https://laskyr.com/plugins/virtue-toolkit"><img src="https://laskyr.com/plugins/virtue-toolkit/badge.svg" alt="Virtue/Ascend/Pinnacle Toolkit vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit