Plugins · vikrentitems · data as of 2026-11-04
Is VikRentItems Flexible Rental Management System safe? Known vulnerabilities and latest version
- Latest version
- 1.2.8
- Last updated
- 2026-10-27
- Active installs
- 600+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Multi-purpose Items Rental Management System for any kind of objects. The most efficient booking solution for managing item rentals through your site. — by e4jvikwp
What to do
- Update to the latest version (1.2.8). Anything older than 1.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get vikrentitems --field=version shows what you run; wp plugin update vikrentitems updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.6 CVE-2026-88926 · published 2026-09-19
SQL injection in VikRentItems Flexible Rental Management System (older than 1.2.4)
- Affected
- older than 1.2.4
- Fixed in
- 1.2.4
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The VikRentItems Flexible Rental Management System WordPress plugin before 1.2.4 does not sanitise and escape some of its parameters before using them in SQL statements, allowing unauthenticated users to perform SQL injection attacks.
high 7.2 CVE-2026-16143 · published 2026-08-05
Stored cross-site scripting (XSS) in VikRentItems Flexible Rental Management System (1.2.1 and older)
- Affected
- 1.2.1 and older
- Fixed in
- 1.2.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The VikRentItems – Flexible Rental Management System plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the customer email field of the booking checkout form in versions up to, and including, 1.2.1. This is due to insufficient input sanitization and output escaping in the saveorder() function, which stores the raw email value via VikRequest::getString() (applying only sanitize_text_field(), which does not neutralize HTML attribute-breaking characters such as double quotes), and in the editorder template which echoes the stored custmail value into an HTML input element's value attribute without esc_attr(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-16143Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2025-14049 · published 2025-12-12
Reflected cross-site scripting (XSS) in VikRentItems Flexible Rental Management System (1.2.0 and older)
- Affected
- 1.2.0 and older
- Fixed in
- 1.2.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The VikRentItems Flexible Rental Management System plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'delto' parameter in all versions up to, and including, 1.2.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
NVD CVE-2025-14049Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-27 — latest release on wordpress.org (1.2.8).
- 2026-09-19 — SQL injection disclosed (CVE-2026-88926), fixed in 1.2.4.
- 2026-08-05 — Stored cross-site scripting (XSS) disclosed (CVE-2026-16143), fixed in 1.2.2.
- 2025-12-12 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-14049), fixed in 1.2.1.
Get an email when VikRentItems Flexible Rental Management System has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for VikRentItems Flexible Rental Management System (vikrentitems) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by e4jvikwp (5 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/vikrentitems (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/vikrentitems"><img src="https://laskyr.com/plugins/vikrentitems/badge.svg" alt="VikRentItems Flexible Rental Management System vulnerability status"></a>