Skip to content
Laskyr

Plugins · vikappointments · data as of 2026-11-04

Is VikAppointments Services Booking Calendar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.23)

As of 2026-11-04. 4 issues are on record for older versions; version 1.2.22 or newer fixes all of them that state a fix.

Latest version
1.2.23
Last updated
2026-10-21
Active installs
500+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A reliable tool for managing any kind of appointments, scheduling the bookings of various services, and organizing the calendars of several employees. — by e4jvikwp

What to do

  1. Update to the latest version (1.2.23). Anything older than 1.2.22 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get vikappointments --field=version shows what you run; wp plugin update vikappointments updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.1 CVE-2026-87115 · published 2026-10-03

Arbitrary file deletion in VikAppointments Services Booking Calendar (1.2.21 and older)

Affected
1.2.21 and older
Fixed in
1.2.22 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The VikAppointments Services Booking Calendar plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the extract function in all versions up to, and including, 1.2.21. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). Exploitation requires at least one File-type custom field to be published on the confirmation page shortcode, as this field is not created by default during plugin installation.

NVD CVE-2026-87115Wordfence advisoryCode change (fix)Plugin source

critical 9.3 CVE-2026-84768 · published 2026-09-03

SQL injection in VikAppointments Services Booking Calendar (1.2.20 and older)

Affected
1.2.20 and older
Fixed in
1.2.21
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in VikAppointments Services Booking Calendar <= 1.2.20 versions.

NVD CVE-2026-84768Patchstack advisory

high 7.5 CVE-2026-15918 · published 2026-08-05

SQL injection in VikAppointments Services Booking Calendar (1.2.19 and older)

Affected
1.2.19 and older
Fixed in
1.2.20 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

VikAppointments Service Booking Calendar wordpress plugin is vulnerable to unauthenticated SQL injection due to one of the parameters that controls how the public reviews list is sorted is taken from the incoming request and used to build a database query without proper validation or sanitization. Because this value is placed directly into the query, an attacker who is not logged in can inject arbitrary SQL through a normal booking page and read data from the site's database — including sensitive information such as WordPress user credentials. No authentication or special privileges are required

NVD CVE-2026-15918Wordfence advisoryPlugin source

high 7.1 CVE-2025-22719 · published 2025-01-21

Stored cross-site scripting (XSS) in VikAppointments Services Booking Calendar (1.2.16 and older)

Affected
1.2.16 and older
Fixed in
1.2.17
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in e4jvikwp VikAppointments Services Booking Calendar vikappointments allows Stored XSS.This issue affects VikAppointments Services Booking Calendar: from n/a through <= 1.2.16.

NVD CVE-2025-22719Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
VikAppointments Services Booking Calendar vulnerability status badge
<a href="https://laskyr.com/plugins/vikappointments"><img src="https://laskyr.com/plugins/vikappointments/badge.svg" alt="VikAppointments Services Booking Calendar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit