Plugins · vigilante · data as of 2026-11-04
Is Vigilant safe? Known vulnerabilities and latest version
- Latest version
- 3.0.10
- Last updated
- 2026-11-01
- Active installs
- 3,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Premium WordPress Security - 100% FREE: Firewall, 2FA, Security Headers, Login and Malware Protection, File Monitor, Security Audit & more — by Fernando Tellado
What to do
- Update to the latest version (3.0.10). Anything older than 2.10.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get vigilante --field=version shows what you run; wp plugin update vigilante updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-81754 · published 2026-09-11
Stored cross-site scripting (XSS) in Vigilant (2.10.2 and older)
- Affected
- 2.10.2 and older
- Fixed in
- 2.10.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Vigilant – 100% Free Security Suite: Firewall, 2FA, Login, Headers, Scanner… plugin for WordPress is vulnerable to Stored Cross-Site Scripting via User-Agent Header in all versions up to, and including, 2.10.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The malicious payload is delivered passively by any unauthenticated visitor who triggers a failed login attempt with a crafted User-Agent header, requiring no further interaction from the attacker once stored.
NVD CVE-2026-81754Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-11-01 — latest release on wordpress.org (3.0.10).
- 2026-09-11 — Stored cross-site scripting (XSS) disclosed (CVE-2026-81754), fixed in 2.10.3.
Get an email when Vigilant has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Vigilant (vigilante) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/vigilante (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/vigilante"><img src="https://laskyr.com/plugins/vigilante/badge.svg" alt="Vigilant vulnerability status"></a>