Plugins · views-for-wpforms-lite · data as of 2026-11-04
Is Views for WPForms safe? Known vulnerabilities and latest version
- Latest version
- 3.4.9
- Last updated
- 2026-08-22
- Active installs
- 1,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.6+
Display and Edit WPForms Entries Directly on Your Website with No Coding Knowledge Needed. — by Aman
What to do
- Update to the latest version (3.4.9). Anything older than 3.4.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get views-for-wpforms-lite --field=version shows what you run; wp plugin update views-for-wpforms-lite updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.5 CVE-2026-42742 · published 2026-05-12
SQL injection in Views for WPForms (3.4.6 and older)
- Affected
- 3.4.6 and older
- Fixed in
- 3.4.7
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Aman Views for WPForms views-for-wpforms-lite allows Blind SQL Injection.This issue affects Views for WPForms: from n/a through <= 3.4.6.
medium 4.3 CVE-2024-0374 · published 2024-02-05
Cross-site request forgery (CSRF) in Views for WPForms (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Views for WPForms – Display & Edit WPForms Entries on your site frontend plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.2. This is due to missing or incorrect nonce validation on the 'create_view' function. This makes it possible for unauthenticated attackers to create views via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
medium 4.3 CVE-2024-0370 · published 2024-02-05
Missing authorization check in Views for WPForms (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Views for WPForms – Display & Edit WPForms Entries on your site frontend plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'save_view' function in all versions up to, and including, 3.2.2. This makes it possible for authenticated attackers, with subscriber access and above, to modify the titles of arbitrary posts.
medium 4.3 CVE-2024-0371 · published 2024-02-05
Missing authorization check in Views for WPForms (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Views for WPForms – Display & Edit WPForms Entries on your site frontend plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'create_view' function in all versions up to, and including, 3.2.2. This makes it possible for authenticated attackers, with subscriber access and above, to create form views.
medium 4.3 CVE-2024-0372 · published 2024-02-05
Missing authorization check in Views for WPForms (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Views for WPForms – Display & Edit WPForms Entries on your site frontend plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'get_form_fields' function in all versions up to, and including, 3.2.2. This makes it possible for authenticated attackers, with subscriber access and above, to create form views.
medium 4.3 CVE-2024-0373 · published 2024-02-05
Cross-site request forgery (CSRF) in Views for WPForms (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Views for WPForms – Display & Edit WPForms Entries on your site frontend plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.2.2. This is due to missing or incorrect nonce validation on the 'save_view' function. This makes it possible for unauthenticated attackers to modify arbitrary post titles via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Recent activity
- 2026-08-22 — latest release on wordpress.org (3.4.9).
- 2026-05-12 — SQL injection disclosed (CVE-2026-42742), fixed in 3.4.7.
- 2024-02-05 — Cross-site request forgery (CSRF) disclosed (CVE-2024-0374), fixed in 3.2.3.
- 2024-02-05 — Missing authorization check disclosed (CVE-2024-0370), fixed in 3.2.3.
Get an email when Views for WPForms has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Views for WPForms (views-for-wpforms-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Aman (4 tracked)
Types found in this plugin: Missing authorization (3) · Cross-site request forgery (CSRF) (2) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/views-for-wpforms-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/views-for-wpforms-lite"><img src="https://laskyr.com/plugins/views-for-wpforms-lite/badge.svg" alt="Views for WPForms vulnerability status"></a>