Skip to content
Laskyr

Plugins · videographywp · data as of 2026-11-04

Is Featured Video for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.20)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.20 or newer fixes all of them that state a fix.

Latest version
1.0.20
Last updated
2026-10-02
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WordPress featured video plugin that allows you to create video posts from YouTube videos. — by CodeFlavors

What to do

  1. Update to the latest version (1.0.20). Anything older than 1.0.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get videographywp --field=version shows what you run; wp plugin update videographywp updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-62746 · published 2025-12-30

Stored cross-site scripting (XSS) in Featured Video for WordPress (1.0.18 and older)

Affected
1.0.18 and older
Fixed in
1.0.20
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CodeFlavors Featured Video for WordPress – VideographyWP videographywp allows Stored XSS.This issue affects Featured Video for WordPress – VideographyWP: from n/a through <= 1.0.18.

NVD CVE-2025-62746Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Featured Video for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/videographywp"><img src="https://laskyr.com/plugins/videographywp/badge.svg" alt="Featured Video for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit