Plugins · video-playlist-and-gallery-plugin · data as of 2026-11-04
Is Cincopa video and media plug-in safe? Known vulnerabilities and latest version
- Latest version
- 1.165
- Last updated
- 2026-07-28
- Active installs
- 1,000+
- Known issues on record
- 5
- Unpatched in latest
- 1
- Tested up to WP
- 7.0.8
Post your videos, photo galleries, slideshows, music and playlists easily and in seconds. — by nicashmu
What to do
- There is no fixed version yet. If you can live without Cincopa video and media plug-in for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get video-playlist-and-gallery-plugin --field=version shows what you run; wp plugin update video-playlist-and-gallery-plugin updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 1.165 CVE-2026-54864 · published 2026-10-29
Cross-site scripting (XSS) in Cincopa video and media plug-in (1.165 and older)
- Affected
- 1.165 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Post Video Players <= 1.165 versions.
high 7.2 CVE-2026-10092 · published 2026-06-24
Stored cross-site scripting (XSS) in Cincopa video and media plug-in (1.163 and older)
- Affected
- 1.163 and older
- Fixed in
- 1.164 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Cincopa video and media plug-in plugin for WordPress is vulnerable to Stored Cross-Site Scripting via cincopa Shortcode in Post Comments in all versions up to, and including, 1.163 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation is possible because the plugin processes the [cincopa] shortcode via a comment_text filter hook, allowing unauthenticated visitors who can post comments to supply a malicious shortcode argument that persists in the database.
medium 4.3 CVE-2025-62143 · published 2025-12-31
Information disclosure in Cincopa video and media plug-in (1.163 and older)
- Affected
- 1.163 and older
- Fixed in
- 1.164 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Exposure of Sensitive System Information to an Unauthorized Control Sphere vulnerability in nicashmu Post Video Players video-playlist-and-gallery-plugin allows Retrieve Embedded Sensitive Data.This issue affects Post Video Players: from n/a through <= 1.163.
medium 5.9 CVE-2025-62142 · published 2025-12-31
Stored cross-site scripting (XSS) in Cincopa video and media plug-in (1.163 and older)
- Affected
- 1.163 and older
- Fixed in
- 1.164 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in nicashmu Post Video Players video-playlist-and-gallery-plugin allows Stored XSS.This issue affects Post Video Players: from n/a through <= 1.163.
medium 5.4 CVE-2024-23515 · published 2024-03-27
Cross-site request forgery (CSRF) in Cincopa video and media plug-in (1.159 and older)
- Affected
- 1.159 and older
- Fixed in
- 1.160
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Cincopa Post Video Players.This issue affects Post Video Players: from n/a through 1.159.
Recent activity
- 2026-07-28 — latest release on wordpress.org (1.165).
- 2026-10-29 — Cross-site scripting (XSS) disclosed (CVE-2026-54864), no fix listed yet.
- 2026-06-24 — Stored cross-site scripting (XSS) disclosed (CVE-2026-10092), fixed in 1.164.
- 2025-12-31 — Information disclosure disclosed (CVE-2025-62143), fixed in 1.164.
Get an email when Cincopa video and media plug-in has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Cincopa video and media plug-in (video-playlist-and-gallery-plugin) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Sensitive data exposure (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/video-playlist-and-gallery-plugin (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/video-playlist-and-gallery-plugin"><img src="https://laskyr.com/plugins/video-playlist-and-gallery-plugin/badge.svg" alt="Cincopa video and media plug-in vulnerability status"></a>