Skip to content
Laskyr

Plugins · video-gallery-block · data as of 2026-11-04

Is Video Gallery Block safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.7.0 or newer fixes all of them that state a fix.

Latest version
1.7.0
Last updated
2026-11-04
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Show a YouTube channel, playlist or Vimeo videos as a gallery that updates itself. Free video SEO, GDPR consent and Google Analytics tracking. — by bPlugins

What to do

  1. Update to the latest version (1.7.0). Anything older than 1.7.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get video-gallery-block --field=version shows what you run; wp plugin update video-gallery-block updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-52709 · published 2026-10-29

Stored cross-site scripting (XSS) in Video Gallery Block (1.6.0 and older)

Affected
1.6.0 and older
Fixed in
1.7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Video Gallery Block video-gallery-block allows Stored XSS.This issue affects Video Gallery Block: from n/a through 1.6.0.

NVD CVE-2026-52709Patchstack advisory

medium 6.5 CVE-2025-27326 · published 2025-07-04

Stored cross-site scripting (XSS) in Video Gallery Block (1.1.0 and older)

Affected
1.1.0 and older
Fixed in
1.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Video Gallery Block video-gallery-block allows Stored XSS.This issue affects Video Gallery Block: from n/a through <= 1.1.0.

NVD CVE-2025-27326Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Video Gallery Block vulnerability status badge
<a href="https://laskyr.com/plugins/video-gallery-block"><img src="https://laskyr.com/plugins/video-gallery-block/badge.svg" alt="Video Gallery Block vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit