Skip to content
Laskyr

Plugins · viable-url-media-uploader · data as of 2026-11-04

Is Viable URL Media Uploader safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.1 or newer fixes all of them that state a fix.

Latest version
1.1.0
Last updated
2026-10-22
Active installs
90+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Media uploader that adds attachments from URLs to your WordPress media library. Upload images, videos, PDFs, and more with just a URL. — by Ahsan Amin

What to do

  1. Update to the latest version (1.1.0). Anything older than 1.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get viable-url-media-uploader --field=version shows what you run; wp plugin update viable-url-media-uploader updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-14564 · published 2026-09-30

Stored cross-site scripting (XSS) in Viable URL Media Uploader (1.0.0 and older)

Affected
1.0.0 and older
Fixed in
1.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Viable URL Media Uploader plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 1.0.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.

NVD CVE-2025-14564Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Viable URL Media Uploader vulnerability status badge
<a href="https://laskyr.com/plugins/viable-url-media-uploader"><img src="https://laskyr.com/plugins/viable-url-media-uploader/badge.svg" alt="Viable URL Media Uploader vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit