Skip to content
Laskyr

Plugins · vc-addons-by-bit14 · data as of 2026-11-04

Is Web and WooCommerce Addons for WPBakery Builder safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.1)

As of 2026-11-04. 3 issues are on record for older versions; version 1.6 or newer fixes all of them that state a fix.

Latest version
1.6.1
Last updated
2026-10-23
Active installs
1,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Clean, responsive, well designed addons for WPBakery Page Builder with custom post type — by Shamim Rajani

What to do

  1. Update to the latest version (1.6.1). Anything older than 1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get vc-addons-by-bit14 --field=version shows what you run; wp plugin update vc-addons-by-bit14 updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-62748 · published 2025-12-31

Cross-site scripting (XSS) in Web and WooCommerce Addons for WPBakery Builder (1.5 and older)

Affected
1.5 and older
Fixed in
1.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Genetech Products Web and WooCommerce Addons for WPBakery Builder vc-addons-by-bit14 allows DOM-Based XSS.This issue affects Web and WooCommerce Addons for WPBakery Builder: from n/a through <= 1.5.

NVD CVE-2025-62748Patchstack advisory

medium 4.8 CVE-2024-43960 · published 2024-08-29

Stored cross-site scripting (XSS) in Web and WooCommerce Addons for WPBakery Builder (1.4.6 and older)

Affected
1.4.6 and older
Fixed in
1.4.7 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Page Builder Addons Web and WooCommerce Addons for WPBakery Builder allows Stored XSS.This issue affects Web and WooCommerce Addons for WPBakery Builder: from n/a through 1.4.6.

NVD CVE-2024-43960Patchstack advisory

medium 4.3 CVE-2024-6579 · published 2024-07-16

Missing authorization check in Web and WooCommerce Addons for WPBakery Builder (1.4.5 and older)

Affected
1.4.5 and older
Fixed in
1.4.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Web and WooCommerce Addons for WPBakery Builder plugin for WordPress is vulnerable to unauthorized plugin settings modification due to a missing capability check on several plugin functions in all versions up to, and including, 1.4.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change some of the plugin settings.

NVD CVE-2024-6579Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Web and WooCommerce Addons for WPBakery Builder vulnerability status badge
<a href="https://laskyr.com/plugins/vc-addons-by-bit14"><img src="https://laskyr.com/plugins/vc-addons-by-bit14/badge.svg" alt="Web and WooCommerce Addons for WPBakery Builder vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit